8 Replies Latest reply: Jun 24, 2016 12:03 PM by Richard Bird RSS

    QMC slow for Document Administrators primarily

    Michael Box

      Our Document Administrators are experiencing slower and slower response time when doing anything on the console.  This usually leads to the message "Processing ... please wait" appearing on the screen.  Before their privileges were reduced to Document Administrators they had full-blown administor rights on the console and never had this problem.  As an administrator myself, I am not experiencing any problems.  I implemented the fix documented here (https://community.qlik.com/message/895403#895403) regarding cross domains.  REstarting the services did not work so I rebooted the server.  This seemed to have corrected the problem, but it is now starting to happen again.  It seems to get progressively worse with time.  I rebooted the server this morning and response time improved but they are still experiencing slowness.  Any thoughts?

       

      Thanks,

      Michael

        • Re: QMC slow for Document Administrators primarily
          Bill Markham

          May well be a memory leak.

           

          I would first ensure the server has the latest recommended Microsoft Server o/s patches applied and if still dodgy then lodge a call with Qlik Support.

          • Re: QMC slow for Document Administrators primarily
            Marco Wedel

            Hi,

             

            I guess you are experiencing the issue described also in this thread:

            Settings to cache user credentials in QMC to improve QMC performance

             

            If that's the case, then one solution would be:

             

            • Go to C:\Program Files\QlikView\Management Service
            • Add / Change the following configuration key in QVManagementService.exe.config

                      <!-- DocumentFolder Admin Cache Enabled -->

                      <add key="DocumentFolderAdminCacheEnabled" value="true" />

                      <!-- DocumentFolder Admin Cache Expiry in minutes -->

                      <add key="DocumentFolderAdminCacheExpiryMinutes" value="15" />

            • Restart the QMS.exe

             

            hope this helps

             

            regards

             

            Marco

            • Re: QMC slow for Document Administrators primarily
              Michael Box

              Well, I made the suggested changes and rebooted the server Friday.  By this morning response time was again incredibly slow.  I added a single user, as a test, to the QlikView Administration group on the server, had him exit the console and re-open, and he hasn't had any problems since.  Looks like I'm headed to Support.  Thanks for the input gentlemen.

               

              Michael

              • Re: QMC slow for Document Administrators primarily
                Michael Box

                I made a couple of changes late yesterday as recommended by Support and the issue appears to be resolved.  First, I neglected to create a QlikView Document Administrators local group on the server.  Next, when I setup the Document Administrators I used their Active Directory group.  I changed this to the individual ID rather than the group and all appears to be working.  Just wanted to post this information should anyone else face the same issue.

                  • Re: QMC slow for Document Administrators primarily
                    Richard Bird

                    I don't totally understand what you mean by "I neglected to create a QlikView Document Administrators local group on the server" Can you elaborate?


                    We are seeing similar issues with Document Admin slowness. I was already instructed by support to set this:

                    <!-- DocumentFolder Admin Cache Enabled -->

                              <add key="DocumentFolderAdminCacheEnabled" value="true" />

                              <!-- DocumentFolder Admin Cache Expiry in minutes -->

                              <add key="DocumentFolderAdminCacheExpiryMinutes" value="15" />

                     

                    Which I have done. This didn't fix the issue. Users are still seeing the same thing.

                      • Re: QMC slow for Document Administrators primarily
                        Michael Box

                        Hi Richard,

                         

                        I had to remote into the server, navigate to Computer Management --> System Tools --> Local Users and Groups --> Groups.  Here I created a QlikView Document Administrators group and added the users there.

                         

                        There are also some things that have to be done within the management console:

                        • On System --> Setup --> QlikView Servers --> Folder Access I added the users to the Whole Server
                        • On System --> Setup --> Distribution Service --> General add the paths for sourcedocs and QVDGen, then add the users for each

                        Note that in both of these cases the user's ID must be used, not the a security group.

                         

                        Hope this helps ...