5 Replies Latest reply: Oct 19, 2010 12:17 PM by Karl Pover RSS

    Data in qvw not updating through publisher

      We reload all data into QVDs. We then reload a separate qvw that only uses the qvds. When the job runs nightly new qvds are created with updated data but the new data in the qvds in not picked by the second qvw load. If I run the job manually through the publisher the new data shows up?

      This has just started happening recently and it is only happening on one QVW which leads me to believe this is caused by a change I made to the qvw. I did recently add a macro could this have any impact?

        • Data in qvw not updating through publisher
          Karl Pover

          Is the reload of the QVW file dependent or triggered to run after creating the QVDs? Is the reload run in parallel with others reloads? If the reload runs well when started manually from the publisher or from the developer it should run fine if scheduled. The macro shouldn't make a difference. If it is run with other documents it could run out of memory. Does the log tell you anything?

          I would try playing with the schedule when it is run to make sure it runs alone and after the QVDs are reloaded.

          Regards.

            • Data in qvw not updating through publisher

              The reload is dependent to run after the QVD creation. There may be other jobs running while this reload is running. I can't see anything in the log files. Both jobs complete successfully and run in almost the same exact amount of time. I will try to find a more isolate window well after the QVD reload is finished. I will report back.

               

              Thanks

                • Data in qvw not updating through publisher

                  Update:

                  QVD load finished at 6:03 AM

                  QVW load run SCHEDULED at 6:40 AM FAILURE (nothing else running )

                  QVW load run MANUAL at 7:00 AM FAILURE

                  QVW load runs SCHEDULED at 7:20 AM FAILURE

                  QVW load runs MANUAL at 8:24 AM SUCCESS

                  When I say failure, the job is not failing. It runs fine with no errors or warning but the data does not refresh.

                    • Data in qvw not updating through publisher

                      Log files. Notice they look exactly the same except for the file size in the successlog changes after the reload.

                      QVD load is finishing at 6:03. No way that the QVDs are not refreshed when the job runs at 6:40

                        • Data in qvw not updating through publisher
                          Karl Pover

                          I noticed you are reloading and then distributing to a QVS Server. Does the original source document update properly? Does both the original and user document not update properly? Is the original source doucment the same document as the user document?

                          Since it's failure and success are inconsistant, could some other process be using the file and prevent it from being distributed correctly?

                          Sorry, more questions than answers.

                          Regards.