3 Replies Latest reply: May 4, 2017 12:19 AM by Lech Miszkiewicz RSS

    NPrinting Designer stalling on Excel Template

    Guy Meintjes

      Hi all,

      I'm running NPrinting 17.2 (Though the problem was there in the previous version). When I create an Excel report and select Edit Template the NPrinting Designer splash screen shows, then disappears and nothing else happens (The Designer interface does not appear). The Designer application is running (I can see it in the task manager) and it has started an instance of MS Excel (2013). If I end the Excel process the Designer interface appears, however, I now get RPC errors as the Excel instance is gone. It's worth mentioning that all other template types work without a problem. Other clients using the same server work just fine. I've tried the following:

      • Refreshing NPrinting Designer install & updating both the server version and Designer version.
      • Setting Designer to open using administrative permissions.
      • Refreshing my MS Office installation etc.

      All to no avail. If anyone has an easy fix I might be missing I would be extremely grateful.

        • Re: NPrinting Designer stalling on Excel Template
          Teemu Pitkänen

          Hey Guy,

           

          I've had a lot of issues with version 17.2. Not quite what you're experiencing but I'd try to update to version 17.2.1 if it's not too much of a hassle. It seems to have a lot of bug fixes and solved basically all my issues.


          -Teemu

          • Re: NPrinting Designer stalling on Excel Template
            Guy Meintjes

            So it seems that the issue relates to screen scaling. Many thanks to South Africa Qlik Master Reseller's support team for the fix. They gave the following options which solved the issue (specifically option 3 in my case):

            1. Set the "Change the size of text, apps and other items" property equal to 100% in the main display.
            2. If you have 2 monitors set the main display that has the property equal to 100%.
            3.   Enable the "Disable display scaling on high DPI settings" property, that you can find in the properties of the NPrinting.exe application (C:\Program Files (x86)\NPrinting\Client), in the “Compatibility” tab. This option renders the Designer layout quite bad