9 Replies Latest reply: May 7, 2014 4:20 AM by ano milo RSS

    Problems with QlikView Access Point / user performance

    Klaus Feldam

      Server: Windows 2008 R2 Enterprise SP1 x64

      Server CPU – 8 x 2.13GHz Intel Xeon

      Server Memory – 64GB

      QlikView Server: 9.00.7320.7 SR2 64-bit (x64)

      Web Server: QlikView (IIS NOT installed)

       

      Clients: Internet Explorer IE Plug-In / AJAX – Windows XP and Windows 7

      QlikView IE PlugIn Client: 9.00.7320.7 SR2

       

      We have had several examples over the past two weeks, where users have been unable to access QlikView applications.

      The QlikView AccessPoint would show up, but none of the QliKView applications they would normally see when they log in. See attached example.

       

      At the point where the users are unable to access their reports, the server CPU and memory utilization are below 20—30%.

      The resolution is ALWAYS to stop the QlikView Server service and restart it. After the restart, the users are able to access their reports. This is highly disrupting and unexpected behavior.

       

      From the log files, I am confused why we would see several examples of the following message, although we don’t have IIS installed:

      504         Information        Session stop reason: invalid iis authentication string

       

      Last example of a time, where QlikView became unavailable to our users was today (05/10/2011 14:06 – 14:23). The log files report the following unhelpful information. During the 2:06pm-2:23pm period, 200+ users were unable to access their QlikView application until we stopped and re-started the QlikView Server service.

      2011-05-09 22:55:02        2011-05-10 14:06:29        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:10:42        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:14:00        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:15:28        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:19:52        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:21:53        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:22:15        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:22:26        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:22:48        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:22:59        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:23:32        4              504         Information        Session stop reason: Session expired after idle time

      2011-05-09 22:55:02        2011-05-10 14:29:44        4              500         Information        Debug: CNTService::Handler(4)

      2011-05-09 22:55:02        2011-05-10 14:29:44        4              500         Information        Debug: CNTService::OnInterrogate()

      2011-05-09 22:55:02        2011-05-10 14:29:44        4              500         Information        Debug: Updating status (4080496, 4)

      2011-05-09 22:55:02        2011-05-10 14:41:08        4              500         Information        Debug: CNTService::Handler(1)

      2011-05-09 22:55:02        2011-05-10 14:41:08        4              500         Information        Debug: CNTService::SetStatus(4080496, 3)

      2011-05-09 22:55:02        2011-05-10 14:41:08        4              500         Information        Debug: CNTService::OnStop()

      2011-05-09 22:55:02        2011-05-10 14:41:08        4              500         Information        Debug: Updating status (4080496, 3)

      2011-05-09 22:55:02        2011-05-10 14:41:09        4              500         Information        Debug: Done Running

       

      Anyone has experienced anything similar?

      I am not really getting anywhere with QlikView support, so any assistance with this would be highly appreciated.

       

      Klaus Feldam

        • Problems with QlikView Access Point / user performance

          We had same expierences with Qlikview 9. Often when someone made a lot of calculations the accesspoint acted like being down. It showed no documents to view. A restart of the qlikview server service fixed the problem untill the next time the user made large calculations. it was unpredictable when it would happen, but from time to time it happened. 

           

          We are using Windows Server 2003 X64 SP2  in combination with Qlikview 32 X86 because of ODBC drivers who arent 64 bit compatible. Qlikview Webservice is installed and used.

           

          Yesterday we made the step to Qlikview 10 SR 2 (X86) (Earlier versions had to much bugs that would bother)

          I started on a clean machine, because i would not advise updating an existing version of Qlikview and installed all without problems and then i installed the latest clients and plugins that ships with this version.  And yes, the user who made the calculations can now do his large calculations without "killing"the accesspoint.

           

          But ...yesterday the accesspoint acted like being down and i had to restart the server service again to get the accesspoint working. And today i had to do it twice and i dont know why it's happening.this time.

           

          I've just enabled logging to see if that gets me anywhere.

          So Klaus, you're not alone with that problem, and i will get back on it when i know more.

          • Problems with QlikView Access Point / user performance
            Klaus Feldam

            We have gone through several upgrades since my original question.

            We are now on QV10SR3 and it's still the same issue.

             

            The only workaround is to schedule the QV services to stop and restart daily - preferably after any nightly jobs.

            We used to have the restart scheduled before the nightly jobs, only to have the QV services hang a couple of times, which unfortunately upset the whole night reload schedule. Schedule the stopping/restarting to the early morning hours and you will be fine.

            • Re: Problems with QlikView Access Point / user performance

              hi, i have same issue with my qvs..does anyone have a better solution except restarting the services?

               

              thx