3 Replies Latest reply: Jun 14, 2012 10:05 AM by andrew fundrey RSS

    ODBC connection issue while connecting to Oracle database

      Hi,

       

      I am connecting to Oracle database server (11g) from QlikView 9.0 using ODBC connection. I have around 10 tables from which i am getting data into QlikView. The size of data is around 10 mb. When i start the reload, the connection is established to Oracle Server and data loading starts, but after loading 3-4 tables the loading stucks in between and does not complete. I disabled the antivirus and tried but still no luck. Sometimes the load completes successfully, but most of the time it stucks after loading few tables. Is this a issue with QlikView ? Please let me know if anyone faced such issue and possible resolution.

       

      Thanks,

      Samir

        • ODBC connection issue while connecting to Oracle database
          G�ran Sander

          I am experiencing similar things when retrieving large amounts of information (tens of millions of rows) accessing a PostgreSQL database, with queries taking +5 mins to complete.

           

          I never found a solution, my best guess is that we are looking at a timeout issue either in QlikView or in the ODBC drivers themselves.

           

          My workaround is to incrementally load data from the SQL database, in my case I am loading data for one month at a time into QlikView, looping over all months for which there is data. Works fine, even though you'll have to write some extra script code to set it up.

           

          /Göran