6 Replies Latest reply: Jul 16, 2017 2:09 AM by Peter Lin RSS

    get rid of axis label repetition at trellis

      Hi,

      Since trellis plots are supposed to compare grops on same dimension/axis, repeating axis labels at each trellis panels are redundant at most cases. How to show axis labels at only one panel?

       

      Thanks

      Vlad

       

        • get rid of axis label repetition at trellis
          Chris Cammers

          Did you find a solution to this?

          • get rid of axis label repetition at trellis
            Chris Cammers

            I'm not sure if this is a real solution but If you are not using a combo chart I made the X axis labels hide by changing the position of the axis to Right(Top). It was sort of an accidental discovery. I had converted a split axis combo chart to a simple trellised line chart and the labels vanished. When I changed the position for the expression to the Left Axis they reappeared

            • get rid of axis label repetition at trellis

              Hi Vlad,

               

              Not sure if you are still looking for a solution to this, nor whether or not my proposed workaround is applicable to your certain situation, but I offer the following suggestion in case it helps you or someone else here.

               

              In my document, I have a Trellis of Gauge Charts. I have the "Show Title in Chart" checkbox unchecked (off). Challenge: I found that any Text settings I applied to the Dimension of the chart were being ignored by QlikView Desktop. Good News: I was able to effectively hide the Dimension text, altogether, by completing the following steps:

               

              1. Open the Properties dialogbox for the Chart where Trellis Chart is enabled.

              2. On the "General" tab, temporarily place a checkmark in the "Show Title in Chart" checkbox so that it becomes checked (on).

              3. Click on the "Title Settings..." button.

              4. In the "Title Settings" dialogbox, click the "Font" button.

              5. In the "Font Dialog" dialogbox, click the [Color] button.

              6. In the "Color Area" dialogbox, slide the Transparency to 100%.

              7. Click OK on the "Color Area" dialogbox.

              8. Click OK on the "Font Dialog" dialogbox.

              9. Click OK on the "Title Settings" dialogbox.

              10. Remove the checkmark from the "Show Title in Chart" checkbox so that it becomes unchecked (off).

              11. Click OK on the "Chart Properties" dialogbox.

               

              Result: The Dimension values above each chart in the Trellis are no longer showing.

               

              If you need to add back in some custom labels, simply overlay Text Object(s). Or do what I do and overlay a "Straight Table" with *Horizontal* Presentation and adjust the column-width in order to present more descriptive titles for each chart in the Trellis.

               

              D.Will, ATP Engineering