8 Replies Latest reply: Jun 18, 2017 3:57 PM by Chris Simpson RSS

    Auto refresh of Qlikview document in Browser

       

      Hi,

       

      Is there a way to Auto refresh/reload the qlikview document (in browser)? Currently I am displaying the qlikview document on TV screen. The server is reloaded automatically in 15 minutes interval but the webpage remains the same until a manual refresh is triggered.

       

      Thanks in Advance

       

        • Auto refresh of Qlikview document in Browser
          Miguel Angel Baeyens de Arce

          Hi,

           

          Using the IE Plugin you should be able to refresh (not reload) the document if a new version has been reloaded in Server and it is configured properly. To make sure, open the document, go to the Settings menu, Server, and set Refresh Mode to "Server performs refresh automatically without client action" and click "Enable Push from Server" and "Enable Dynamic Data Update".

           

          Hope that helps.

           

          Miguel Angel Baeyens

          BI Consultant

          Comex Grupo Ibérica

          • Re: Auto refresh of Qlikview document in Browser
            Stig Eide

            Hi, did you manage to solve this issue? We have multiple monitors, and need to wrap the models in iframes+refresh but automatic refresh would be much better. I have these settings, but it still won't work:

            In QMC:

            System>Setup>QVS>Performance>Allow Document Auto Load

            System>Setup>QVS>Security>Enable server push over HTTP tunnels

            qvw Document Properties>Server>Enable Push from Server

            qvw Document Properties>Server>Enable Dynamic Data Update

             

            I have tested both with IE plugin and without, but it does not seem to work.

             

            EDIT: Actually, it looks like it works using the IE plugin. I turned off AJAX in QMC:

            Documents>Source documents>The Task of the qvw>Server>Availability>Access method>Only check IE Client

             

            I had to install the plugin, you can get the URL in Accesspoint by ticking off here in QMC:

            System>Setup>QWS>AccessPoint>Settings>Show link

             

            Now the document reloads automatically when the task to publish is run.

            Only issue is that I can not start the model directly from an URL, I have to open Accesspoint and click on the model. This is not going to work on a public monitor, as it reboots every night so I have to go and click in accesspoint every morning

             

            EDIT 2:

            Using this URL, the document opens up directly:

            http://qvs/QvPlugin/opendoc.htm?document=IT%2FMonitor.qvw

            In addition, I got this receipe from the always helpful bWise support:

            1. In QlikView Management Console (QMC), navigate to System > Setup > QlikView Server > QVS@servername > Documents and check the box “Allow only one copy of document in memory”

            2. Exit the QMC and open the QVW you want to enable Graceful Refresh on (this needs to be done for each and every document you want to enable this feature on), in QlikView Desktop.

            3. Open the Document Properties.

            4. Navigate to Server tab.

            5. Pull down second dropdown bar (Client Refresh Initiation Mode), select “Just Do It”

            6. Pull down the first dropdown bar (Refresh mode when Document is Updated on Server) and select “Server performs refresh automatically without client interaction”.

            7. Save qvw. Graceful Refresh is now enabled.

             

            EDIT3:

            Since we have a "Document Timeout" (under QMC>System>QVS>Documents) set to 120 minutes, it seems like the document actually stops to refresh after this time. What we had to do, is to wrap the URL into an HTML IFRAME that reloads itself every two hours. This will keep the document alive:

            <html>

            <head>

            <meta HTTP-EQUIV="CACHE-CONTROL" CONTENT="NO-CACHE">

            <meta http-equiv="refresh" content="7200">

            </head>

            <body style="overflow:hidden; background-color:#FFFFFF; margin:0;padding:0px; height:100%" scroll="no">

            <iframe src="http://qlikt/QvPlugin/opendoc.htm?document=IT%2FMonitor.qvw" scrolling="no" frameborder="0" border="0" cellspacing="0" style="border-style: none;width: 100%; height: 100%;">

            </iframe>

            </body>

            </html>

             

            Put the above text in an HTML file and start IE in kiosk mode like this:

            "C:\Program Files (x86)\Internet Explorer\iexplore.exe" -k c:\temp\htmlfilabove.html

            Stig

              • Re: Auto refresh of Qlikview document in Browser
                Chris Simpson

                Hi

                 

                I have managed to get my QVW refresh automatically, and works OK on a single screen. If I connect another web page on a different PC to the dashboard, when the refresh happens the web page says it has lost connection to server. it does reconnect.

                 

                Is there a way to stop the lost connection to serve message from appearing.

                 

                Thanks

                Chris