3 Replies Latest reply: Oct 3, 2013 5:51 PM by Sandip Patel RSS

    Problem getting data from html with QV11 server

    Richard de Gruchy

      Hi

       

      We have an app that fetches data (weather and news) from web pages.  It is refreshed by a server task every hour.  Ever since the server has been upgraded to v11 SR1 (build 11.0.11282.0) it fails when it accesses the first HTML page.  It runs fine when run by the desktop version.

       

      I can use QV.exe /r on a schedule to refresh it but this seems to cause occasional issues where the QV.exe application stays open.  I would prefer to use a server refresh, as we do with all our other apps.

       

      This is similar to this discusion:   http://community.qlik.com/message/217368 but this issues appears to have been fixed by QV 10 SR5.  Has the same issue re-occured in v11?

       

      Here is an extract from the log file showing the error

       

      24/08/2012 1:47:00 PM: 0216  FIRST 1 LOAD

      24/08/2012 1:47:00 PM: 0217                                Right([Date/TimeWST], 7) as WeatherNowTime,

      24/08/2012 1:47:00 PM: 0218                           Tmp°C as WeatherNowTemp,

      24/08/2012 1:47:00 PM: 0219                           Wind as WeatherNowWind,

      24/08/2012 1:47:00 PM: 0220                           Wind1 as WeatherNowWindSpeed

      24/08/2012 1:47:00 PM: 0221  FROM                    [http://www.bom.gov.au/products/IDW60901/IDW60901.94614.shtml#other_formats]

      24/08/2012 1:47:00 PM: 0222                                (html, codepage is 1252, embedded labels, table is @2)

      24/08/2012 1:47:00 PM: 0223  WHERE                    [Date/TimeWST] <> 'Date/TimeWST'

      24/08/2012 1:47:02 PM:       Error: Cannot open HTML file

      24/08/2012 1:47:02 PM:       General Script Error

      24/08/2012 1:47:02 PM:       Execution Failed

      24/08/2012 1:47:02 PM:      Execution finished.

       

      Thanks

      beanmachine