1 Reply Latest reply: Dec 19, 2012 5:36 PM by Ralf Becher RSS

    Store to QVD fails. "Table not found"

      Hi,

       

      Im loading a lot of tables into qvd, and in the middle of a load the table measurepoint_temp gives an error. If I comment out the STORE command for the temp table (listed below) the load progresses fine, but naturally doesnt create the qvd. Ive also tried removing the underscore from the naming and filename, but the same error appears:

       

      "Table not found

      STORE measurepoint_TEMP into QVD/metervalue/measurepoint_TEMP"

       

       

       

      measurepoint: LOAD *; SQL SELECT * FROM metervalue.measurepoint; STORE measurepoint into QVD/metervalue/measurepoint.QVD; 
      
      
      measurepoint_TEMP: LOAD *; SQL SELECT * FROM metervalue.measurepoint_TEMP; STORE measurepoint_TEMP into QVD/metervalue/measurepoint_TEMP.QVD;
      
      

       

       

       

      One thing I have noticed in the Script Execution Progress is that both the loads seem to be outputing to the measurepoint table, instead of measurepoint_TEMP for the second one:

       

      Connecting to database;DBQ=database
      Connected
      measurepoint << measurepoint 1 234 567 lines fetched
      measurepoint << measurepoint_TEMP 1 234 567 lines fetched
      

       

       

      Any ideas why this table would cause trouble or suggestions for further debugging?

       

      The only thing Ive found to work is to load them seperatly, commenting out one and loading, and then switching just loading the second table.