2 Replies Latest reply: Nov 21, 2013 9:56 PM by Anton Wibowo RSS

    after running a distribution task, must restart QV server service (qv11)

      hello-

      QV11 SR1: I create distribution tasks that distribute documents to the accesspoint folder, to certain recipients.   The users cannot see the docs in the accesspoint until i restart the Qlikview server service.   Qv server is behaving as though it cannot see the change to the ACLS (permissions list) on the file.  I can manually see that the correct permissions are applied to the file by viewing the security on the file.  But the docs don't appear in the accesspoint until Qv server is restarted.   Only seems to be a problem on new tasks.

       

      Has anyone seen this ?

       

      Tammy

        • Re: after running a distribution task, must restart QV server service (qv11)
          Miguel Angel Baeyens de Arce

          Hi Tammy,

           

          Is the account running the service the same as before happening that? Is the DSC properly configured with an account able to read in the security Directory?

           

          Hope that helps.

           

          Miguel

            • Re: Re: after running a distribution task, must restart QV server service (qv11)
              Anton Wibowo

              Hi Miguel,

               

              I have a follow up question to what you mentioned about the account running the service. Will it matter if the account is different, but both have identical admin access? I have similar issue with what Tammy mentioned, except that it happens to any tasks, not just a new one.


              Note: Not sure if this helps, but this is a brand new server (Server2) that I have Publisher (only QDS & QMC) installed from scratch, but has its configuration migrated from the Server1).


              I migrated the previous Publisher configuration (QV11.2 SR3) by copying over the content of "C:\ProgramData\QlikTech\ManagementService" (which as QVPR folder, qvp_Machine1.ini, reginfo.txt, Publisher.LEF) from Server1 to Server2.


              At the moment, I'm not sure why some files are not distributed properly (there's 1 report I only distributed to myself, but another user with named_cal can see it, even though he's not a recipient) - I'm trying to analyze whether I didn't do the migration & settings properly, or is it because I changed the account running the service.


              Thanks alot for your advise.


              Cheers,

              Anton