Qlik Community

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
pascal_theurot
Partner
Partner

Content libraries access

Hello,

I've some trouble to access content libraries from the hub.

I can access the "Default library" but not the custom's ones.

I use a specific user "easyneo\pat".

I've tried a lot of security associations and even created different content library with different users without success.

1 - content library creation

03-11-2014 18-48-58.jpg

2 - security rules association (in the content library security rules)

(I've also tried the security rules creation from the "security rules" tab)

03-11-2014 18-40-21.jpg

control for the specific user :

03-11-2014 18-40-42.jpg

3 - content access from the hub

Access from the hub to insert images : Only the default content library is displayed :

03-11-2014 18-53-10.jpg

Any idea ?

Pascal
1 Solution

Accepted Solutions
ergustafsson
Partner
Partner

Hi Theurot,

This has been reported as an issue. Using any other content library than default is not supported in the client at the current stage. This functionality is on the roadmap but is currently not in the product.

Regards,

Erik

View solution in original post

9 Replies
ergustafsson
Partner
Partner

Hi Theurot,

This has been reported as an issue. Using any other content library than default is not supported in the client at the current stage. This functionality is on the roadmap but is currently not in the product.

Regards,

Erik

jwheeler
Contributor II
Contributor II

In the document 'Managing a Qlik Sense Site' for 1.1 there is a demonstration of securing a content library (page 158). The section is called "Creating access rights for content libraries".

I just tried creating a content library in 1.1 (latest version), adding a security rule, and the new content library is not showing up within the app.


Can someone from Qlik confirm this functionality is supposed to work (as documented) or is still on the roadmap?


Thanks,

Jacob

Not applicable

Same question as Jacob.

I just tried with 1.1 and it's still not working.

Thanks,

Benoît

Not applicable

When this feature will be in production?

Cheers,

Tommi

korsikov
Partner
Partner

this bug was in the NEXT server and still not fixed.

Emmanuelle__Bustos

With Qlik Sense 2.0.2 is not possible use the custom content yet?

pascal_theurot
Partner
Partner
Author

still not fixed with 2.0.2 version

Pascal
pascal_theurot
Partner
Partner
Author

The good new is that's fully operational from 2.1.1 version.

Additionally, you can now view and upload images directly from Sense Apps.

Pascal
Not applicable

Hi,

is there a way to show dynamic images in textboxes, based on a selection?

Thanks,

Martin