Skip to main content

App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
greg-anderson
Luminary Alumni
Luminary Alumni

Qlik Sense Enterprise Document Analyzer - Connector

I am managing a new QSE for Windows instance, running on AWS

I installed the QS Document Analyzer (1.7) on the server per instructions.

I am trying to create the data connector and getting a WebSocketConnector error message / HTTP 500.

This URL directs to our default virtual proxy, which uses Windows authentication.

I thought it might be related to firewall rules, but I see no blocked traffic. Turned off the server firewall briefly, same result.

Has anyone else seen this?  I have a few apps that really need tuning/trimming.

Hi @rwunderlich, sorry to bug you personally. Been trying to diagnose this connection issue. Any thoughts?

Thanks!

Screen Shot 2020-08-14 at 10.51.44 AM.png

Labels (2)
4 Replies
AnjaliRai
Contributor III
Contributor III

Hi @greg-anderson ,

While creating the QS App Metadata connection , under Hostname, you need to give your Central server details (itseelm-ntservername.com) and then try connecting.
For me, this works perfectly fine.

AnjaliRai_1-1598513281556.png

Hope you find this useful.

--Anjali 

Anjali Rai
greg-anderson
Luminary Alumni
Luminary Alumni
Author

Hi, Anjali. 

Thank you for the reply. 

I am putting my fully-qualified Central server name in the Host box.  Still no luck.

rwunderlich

There is a problem with connection to virtual proxies. Works for some, not for others. I have not been able to determine why.  I've not spent any more time on it as I'm spending all my time on the next version which will change how the connections are made. 

-Rob

paulodantas
Creator
Creator

@greg-anderson what works for me is go to the data connection in QMC and change the string.

Like this:

CUSTOM CONNECT TO "provider=QsAppMetadataConnector.exe;server=CentralMachineName;environment=Enterprise;appid=IdApp;appname=AppName;"

Hope this work for you too.

Best regards.