Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
steffan_holmquist
Partner - Contributor II
Partner - Contributor II

Error during installation: error adding Infra Container: Error parsing image configuration:

Running the QDC installer, during the step: Qlik Licenses & Engine Container Setup, this error appears:

Error: error adding Infra Container: unable to pull k8s.gcr.io/pause:3.2: unable to pull image: Error parsing image configuration: Get https://storage.googleapis.com/us.artifacts.k8s-artifacts-prod.appspot.com/......

We have added this url to the whitelist on the firewall, but the error persists.

Azure cloud server, running RHEL 8

Labels (1)
1 Solution

Accepted Solutions
steffan_holmquist
Partner - Contributor II
Partner - Contributor II
Author

When you provision a RHEL server through Azure, you have the option to use a standard Microsoft O/S image which blocks you from installing or updating some services.

Removed the version lock: https://docs.microsoft.com/en-us/azure/virtual-machines/workloads/redhat/redhat-rhui#switch-a-rhel-8...

After removing the version lock, I had to do three things to get a clean QDC installation:

1. re-install Tomcat

2. chmod 644 /usr/share/rhel/secrets/rhsm/syspurpose/syspurpose.json

3. run QDCinstaller.sh

View solution in original post

2 Replies
steffan_holmquist
Partner - Contributor II
Partner - Contributor II
Author

When you provision a RHEL server through Azure, you have the option to use a standard Microsoft O/S image which blocks you from installing or updating some services.

Removed the version lock: https://docs.microsoft.com/en-us/azure/virtual-machines/workloads/redhat/redhat-rhui#switch-a-rhel-8...

After removing the version lock, I had to do three things to get a clean QDC installation:

1. re-install Tomcat

2. chmod 644 /usr/share/rhel/secrets/rhsm/syspurpose/syspurpose.json

3. run QDCinstaller.sh

danys1
Contributor
Contributor

I had that issue, in my case it was because I forgot to add ´imagePullSecrets:name:’ in the deployment to reference the pull secret