Skip to main content
Announcements
Marching toward a simplified navigation! READ ON
cancel
Showing results for 
Search instead for 
Did you mean: 
ChrisRelt
Contributor
Contributor

57P03 error when selecting Snowflake table

Hi, I have a connection using the native Qlik Sense Snowflake connector. I add data and browse my Snowflake schema in Qlik Sense, I select a view or table and the column names are returned but then I see the following error : "ERROR [57P03] No active warehouse selected in the current session. Select an active warehouse with the 'use warehouse' command."

ChrisRelt_0-1617918731452.png

 

And I'm unable to Insert Script or continue.

Can anyone help me with - where do I set the 'use warehouse' command please ?

Thanks !

Labels (2)
5 Replies
gardenierbi
Creator
Creator

You can define the warehouse in your connection string or ODBC connection!

Senor_Dai
Partner - Creator II
Partner - Creator II

Hi @ChrisRelt did you ever solve this? Im getting the same error...

 

many thanks

 

Dai

NadiaB
Support
Support

Hi @Senor_Dai 

By any chance did you provide a Warehouse in the connection details ?

 

NadiaB_0-1675187066627.png

 

The other option would be to do it programmatically if you are writing the query in the Script Editor to add "use warehouse" statement. The documentation can be found here: 

https://docs.snowflake.com/en/sql-reference/sql/use-warehouse.html

Hope it helps. 

Don't forget to mark as "Solution Accepted" the comment that resolves the question/issue. #ngm
Senor_Dai
Partner - Creator II
Partner - Creator II

Hi @NadiaB - thanks for the reply,  Yes - the warehouse is added to the configuration.  Ive also tried adding a system dsn on the server itself by installing the snowflake odbc driver - but that times out also.

RenuLalwani
Employee
Employee

if it doesn't work with System DSN too, its not a Qlik related issue. 

To me, It looks like the user doesn't have appropriate access to the warehouse. 

It could either be wrong assignment of warehouse to the user. OR you have not grand access to the Warehouse to the role

GRANT USAGE ON WAREHOUSE my_warehouse TO ROLE my_role;