Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Our May 2021 end-to-end product release from Data Integration to Data Analytics is out! READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
KefangWorker
Contributor II
Contributor II

Can't load a data sheet which contained calculation from other tables

Hi, 

I got one failure when I tried to open one sheet in a published app,  The table in it can't show up: 

KefangWorker_0-1623353829438.png

Something special about the table is that it reads the data from another table created in the same app and does further calculation on it.

When we tried to recreated the tables again, it showed up once and crashed again.  We have looked into the Log/Engine/*AuditActivity_Engine*,  it says on this sheet: 

Audit *(Showcase_*)|Not available Engine Not available GenericObject::GetLayout Get layout 0 Success 28b80d4e-f396-4ac2-8d00-af6267bf7bd3 

 

Later, after checking the Log/DataProfiling /*Audit to check the data loading procedure, it says with this sheet, either

Audit WARN 2021-06-10T19:15:15.722+00:00 225074405191.2 Error on web socket connection Error message: Invalid WebSocket frame: invalid status code 2556 RangeError: Invalid WebSocket frame: invalid status code 2556
at e.exports.controlMessage (C:\Program Files\Qlik\Sense\DataPrepService\dataprep-service.bundle.js:115:187352)
at e.exports.getData (C:\Program Files\Qlik\Sense\DataPrepService\dataprep-service.bundle.js:115:186157)
at e.exports.startLoop (C:\Program Files\Qlik\Sense\DataPrepService\dataprep-service.bundle.js:115:183736)
at e.exports._write (C:\Program Files\Qlik\Sense\DataPrepService\dataprep-service.bundle.js:115:183118)
at doWrite (_stream_writable.js:435:12)
at writeOrBuffer (_stream_writable.js:419:5)
at e.exports.Writable.write (_stream_writable.js:309:11)
at TLSSocket.O (C:\Program Files\Qlik\Sense\DataPrepService\dataprep-service.bundle.js:115:179262)
at TLSSocket.emit (events.js:223:5)
at addChunk (_stream_readable.js:309:12)
at readableAddChunk (_stream_readable.js:290:11)
at TLSSocket.Readable.push (_stream_readable.js:224:10)
at TLSWrap.onStreamRead (internal/stream_base_commons.js:181:23) Client closed connection: 7e8b9c64-40c6-444a-9542-dce4f37b7107

Or 

KefangWorker_1-1623354344656.png

RPC is inactive.

 

So we assume that the reason that data can't be loaded  is the connection of RPC doesn't work well due to the Websocket setting. 

But no idea how to improve it. Could you help me to verify the reason for such failed data load and then fix it??

Thanks a lot

Regards

Kefang

 

 

 

0 Replies