Qlik Community

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Data Connection Spinning - Not working

Qlik Sense Desktop when going to Data Connections it just spins.  If I select Create New Connection a blank bar shows up no connection options.  I am unable to bring data into the script.

  HELP!!

24 Replies
HarishG
Partner
Partner

This issue can be solved using below given method,

Go to "C:\Program Files\Common Files\Qlik\Custom Data". You will see folders like QvDataMarketConnector, QvOdbcConnectorPackage, QvRestConnector and QvSalesforceConnector. Inside each folder there would be a config file.

Eg: C:\Program Files\Common Files\Qlik\Custom Data\QvRestConnector\QvRestConnector.exe.config.

Edit config file and add below code just before closing </configuration> tag.

"

<runtime>

  <generatePublisherEvidence enabled="false"/>

</runtime>

"

Save file and do the same with all the connectors. Make sure to stop services before making any changes.

mitchjb2008
Contributor III
Contributor III

I have this same problem; it seems to be intermittent also. I've tried all of the options listed above to no avail.

Can I please get contacted by Qlik to review this?

It would be nice to know where the list of Data Connections loads from and what could possibly impact the proper loading of the connections list...

amien
Specialist
Specialist

Anyone got a solution for this? Latest version still has this issue

mitchjb2008
Contributor III
Contributor III

I don't think there's a fix yet.

I'm really getting sick of two things with Qlik: 1) bugs like this that go unanswered and 2) a general feeling of not having a way to report problems to them directly. Posting concerns on this forum does not guarantee that they have heard about these issues.

mitchjb2008
Contributor III
Contributor III

Dude, the original poster's first three words were "Qlik Sense Desktop." This isn't a complaint about the web server.

raoulis_dimitris
Contributor II
Contributor II

Hi all,

We had same problem of slow rendering sheet and slow showing of connections after upgrading to june 2018 server.

Specifically in google chrome :

  1. Open the app with the Google Chrome
  2. Open the Inspect Element menu (Ctrl + Shift + I)
  3. Select the Network tab
  4. Reload the page
  5. In the menu bellow the Network tab it must be selected the All option
  6. Right click at the list at the bottom of the menu and select the “Save as HAR with content” option

 

error.png

As you can see these errors are referinig connectors: QvOdbcConnectorPackage, the Essbase Connector, the
QvDataMarketConnector and the Qlik Rest Connector are the components who are responsible for the slow response from server.

After removing these folders, we had no issues with our app which is not using these connectors but now we have no problems with license monitor app which needs these connections to reload.


Please advise!

vnelsoncrunch
Partner
Partner

I was seeing this intermittently on desktop and server and today the connection went completely down.

My situation was using an ODBC driver for MS .xlsx imports.

Tried the solutions above for <runtime> and it did not work and also resulted in not being able to start the services back up on Sense Server June 2018.

For Desktop what I found that worked was to go into ODBC drivers, select the driver and under options change to Read Only.  Right after that, the connection was found immediately and the script ran.

I moved the app to my laptop and found the same issue.  Not sure why it worked, began to work intermittently and then completely failed to run starting today.  On a side note, I started having connection issues when I loaded June 2018 and the problem continued even after downgrading. 

2018-08-08_160825.png

lvalencia_psa
Contributor II
Contributor II

Hello,

I recently upgraded to Qlik Sense Desktop June 2018 and when creating a new app I am seeing the same spinning wheel "initializing add data". I am on Windows 7 Pro - 64bit.   Is there an official fix to this yet? 

lvalencia_psa
Contributor II
Contributor II

** Update** After deleting the Source Data folder, and still not working, I opted for Uninstalling and reinstalling Qlik Sense June 2018 edition and it the data connection page is no longer hanging.

Just an FYI.

amien
Specialist
Specialist

I did that too. But after a few days it did come back again.

This really is an issue a quite some version. Dont understand why this is still an issue.

Someone has a solid solution?