Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
vinlandelewis72
Contributor II
Contributor II

Minor issue connecting QlikSense Cloud to SQL Database (ODBC)

Recently installed QlikSense Cloud and pleased all is working well.

However, 1 minor (I think so anyway) problem is that when we try to connect to any SQL (2012) database (via ODBC), we can actually see the database names, but cannot get at the tables within them. Simply the contents are not displayed. But, the strange thing is that we can see the System Databases (master, tempdb, msdb and model) in their entirety.

See attached screens.

Any ideas? QlikSense Engine, Repository or SQL Database owner issue? A setting within the Management Console that needs to change?

Thanks.

NB: Qliksense and SQL Server are hosted on the same (virtual) server.

1 Reply
Not applicable

Well, it has taken a while to figure out and fix but here is the solution:

The SQL databases in question needed to have 'Guest Account Enabled'


1. QlikSense was installed onto its own server with the engine services attributed to LOCAL SYSTEM

2. LOCAL SYSTEM within SQL Server 2012 is [something like] the login NT AUTHORITY\SYSTEM under server>security>logins

3. Within the Properties for NT\AUTHORITY\SYSTEM under Server Roles, enable roles for dbcreator, diskadmin, processadmin, public, serveradmin & sysadmin

4. Flip to User Mapping (still in Properties) and check each database required, is ticked 'Guest Account Enabled'.

As a precaution, stop and restarted the QlikSense Engines.


Hope this helps....reach out if anymore information needed.


*Thanks to Differentia Consulting for initially pointing in the correct direction*