Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
Want to see what's currently in public preview? We've pulled it all together in one place. Check it out here
cancel
Showing results for 
Search instead for 
Did you mean: 
FE_Admin
Contributor
Contributor

Qlik Data Gateway Error 504

Hi,

I am new to Qlik Cloud. Have been using Qlik Enterprise for quite sometime. 

I installed the Qlik Gateway on the same server as BI Server , cause it was having better connectivity with Database and all the ODBC DNS were readily available.

I copied the Registration Key, restarted the Qlik Service , On Qlik Cloud Administration Data Gateways, created a Gateway on the Space and copied the Key and created a Gateway.

It is showing Connected, but when I click on ... (to open the Settings), I am getting following error.

Error

Failed to load the data gateway settings. This may be due to insufficient permissions.

Error: request to '/api/connectivity/direct-access-agents/-Fy4jRj-e27kS4g0dPjcmVG9GD0WeZ3y/connectors/odbc-connector/allowed-drivers' failed with status 504 .

 

It is the same user,nothing changed. 

Can any one help me with this please.

Thanks for your support in advance.

Labels (1)
1 Solution

Accepted Solutions
Andrea_Bertazzo
Support
Support

Hi @FE_Admin 

Please, notice that it is recommended to install DAG on a dedicated server, where no databases or Qlik Products are installed.

Are you able to create connections through DAG? Are they working?

I would suggest to verify your Roles in the tenant and in the space associated with the DAG. You may try with a tenant Admin user having all access levels to the space. Is the problem there also for this user?

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up ! 🙂

View solution in original post

2 Replies
Andrea_Bertazzo
Support
Support

Hi @FE_Admin 

Please, notice that it is recommended to install DAG on a dedicated server, where no databases or Qlik Products are installed.

Are you able to create connections through DAG? Are they working?

I would suggest to verify your Roles in the tenant and in the space associated with the DAG. You may try with a tenant Admin user having all access levels to the space. Is the problem there also for this user?

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up ! 🙂
FE_Admin
Contributor
Contributor
Author

Hi,

Thanks. After going through the detail process of DAG, I reinstalled on a system without any DB or BI instance and it worked.

The issue was not regarding the roles , cause I was created the connection by Admin profile. 

It is solved now, I am able to pull data and work.

Thanks for the solution.