Skip to main content

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
On-Demand Webinar: Learn proven best practices for a smooth transition to Qlik Sense® SaaS. REGISTER
cancel
Showing results for 
Search instead for 
Did you mean: 
andrescc
Contributor III
Contributor III

Qlik SAP SQL Connector

Hi,

Please I need some help. We are using SAP SQL Connector, but I get error no 10054. The test connection its fine, but when I execute the script sometimes works and sometimes I get this:

Se ha producido el siguiente error:
QVX_UNEXPECTED_END_OF_DATA:
LOCATION CPIC (TCP/IP) on local host with Unicode
ERROR connection to partner '172.27.12.72:3333' broken
TIME Wed Feb 13 11:15:57 2019
RELEASE 721
COMPONENT NI (network interface)
VERSION 40
RC -6
MODULE nixxi.cpp
LINE 5082
DETAIL NiIRead: P=xxxxxxxxxx:3333; L=xxxxxxxxx:59635
SYSTEM CALL recv
ERRNO 10054
ERRNO TEXT WSAECONNRESET: Connection reset by peer
COUNTER 5
 
Please help, I've tried many things, but the error still there
 
SAP SQL Connector version 7.0.1
4 Replies
Jay_Brown
Support
Support

Hello Andres,

As this is working intermittently I would first verify that the correct transport (and only those) are installed for the SAP version and connector you are using.  It's possible you could be experiencing intermittent connectivity due to transport conflict.  Please verify this per the help pages:

https://help.qlik.com/en-US/connectors/Subsystems/SAP_Connectors_Help/Content/Connectors_SAP/Install...

Otherwise, are these servers in a local topology?  Same datacenter?  What type of link?   If you suspect the connection is getting interrupted, you may want to try to segment the data into smaller sets and/or reload the data from QVDs.

I hope that helps,

Jay

To help users find verified answers, please don't forget to mark a correct resolution or answer to your problem or question as correct.
LanBiteam
Partner - Contributor III
Partner - Contributor III

Hello Jay,

since we are facing the same problem after we upgrade SAP Connector to 7.0.3. I hope to check with you, how could we tell if this is a problem caused by Transport Conflict?

I have already checked the Release Version and SAP Basis Version and we tried to load only very small amount of Data (50000 lines). I could not see problem and the error log in SAP always exist.

Thanks a lot in advance. 

Lan Cao 

LanBiteam
Partner - Contributor III
Partner - Contributor III

Hi Andrescc.

If you have solved the problem? Can you please share how was your problem?

Thanks a lot,

Lan

 

JensWiesner
Contributor
Contributor

Hello Lan,

have you solved the problem?

After SAP Basis Update we have the Problem.

I also updated the connector to solve the problem.

Thanks

Jens