Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Zenpark_BI
Contributor II
Contributor II

Qlik Web Connector - Drive & Spreadsheets Connector - Error 400 Bad Request

Hello, 

This morning, the task allowing the refreshing of all my data from spreadsheet have failed with a "Internal Server Error".

 

To try and resolve the problem I've tried :

- updating the web connector from March 20 to December 20 (including patch)

- updating the Qlik Sense version from February 21 Patch 1 to February 21 Patch 4

- re-authenticate with the "CanAuthenticate" table from the connector (successfully)

- used the "ListWorksheets" table from the connector (successfully)

- copy-paste the worksheet key listed above to the "GetWorksheet" and it failed with the "Error 400 Bad Request" (see below)

Zenpark_BI_0-1620112390922.png

 

Here is part of the associated log : 

<xml>
    <LogEntry version="1.0.3">
        <Id>73250ee0-4ba2-445a-9825-5c13c688838f_1309</Id>
        <Datetime>04-05-2021 04:05:18.075</Datetime>
        <Type>Info</Type>
        <Sender>GoogleDriveConnector.GoogleDriveConnector</Sender>
        <ServerMode>true</ServerMode>
        <Version>2.77.2.16947</Version>
        <Message>Starting table load GoogleDriveConnector.GetWorksheet</Message>
        <Exception>NA</Exception>
        <ExceptionMessage>NA</ExceptionMessage>
        <AdditionalInfo>
            <RequestId>08cd12b6-2438-4a86-ad7b-1a565107136a</RequestId>
            <ConnectorId>GoogleDriveConnector</ConnectorId>
            <Table>GetWorksheet</Table>
        </AdditionalInfo>
    </LogEntry>
    <LogEntry version="1.0.3">
        <Id>73250ee0-4ba2-445a-9825-5c13c688838f_1313</Id>
        <Datetime>04-05-2021 04:05:19.315</Datetime>
        <Type>Warn</Type>
        <Sender>APIConnectorInterfaces.HTTP_and_Authorisation.Retry.WebRequestRetrier`1[System.String]</Sender>
        <OriginalSender>APIConnectorEngine.Qwc.HttpHelper</OriginalSender>
        <ServerMode>true</ServerMode>
        <Version>2.77.2.16947</Version>
        <WebStatusCode>400</WebStatusCode>
        <WebStatusDescription>Bad Request</WebStatusDescription>
        <WebExcp>System.Net.WebException: The remote server returned an error: (400) Bad Request.

 

How can I fix this issue ? 

Labels (1)
1 Solution

Accepted Solutions
PadmaPriya
Support
Support

Hello @Zenpark_BI 

 

Thanks for posting your query.

 

Error:

Qlik Web connectors, google spreadsheets connector Error "The remote server returned an error: (400) Bad Request."

 

Solution:


Please follow below article:

https://community.qlik.com/t5/Knowledge-Base/Qlik-Web-connectors-google-spreadsheets-connector-Error...

 

Thanks,

Padma Priya

We are just 'like' you and like to be liked when providing a helpful answer. You may press the 'Solution Accepted' button if an answer provided solves your issue.

View solution in original post

5 Replies
p_verkooijen
Partner
Partner

Same here, several of our clients have this issue.

So it seems Gdrive related, not webconnector. 

p_verkooijen
Partner
Partner

Zenpark_BI
Contributor II
Contributor II
Author

Thank you for linking another post about this issue ! 

 

I'm not keen on making the sheet public so I will wait for the resolution of the issue or an alternative workaround.

PadmaPriya
Support
Support

Hello @Zenpark_BI 

 

Thanks for posting your query.

 

Error:

Qlik Web connectors, google spreadsheets connector Error "The remote server returned an error: (400) Bad Request."

 

Solution:


Please follow below article:

https://community.qlik.com/t5/Knowledge-Base/Qlik-Web-connectors-google-spreadsheets-connector-Error...

 

Thanks,

Padma Priya

We are just 'like' you and like to be liked when providing a helpful answer. You may press the 'Solution Accepted' button if an answer provided solves your issue.

View solution in original post

Zenpark_BI
Contributor II
Contributor II
Author

Hello,

Everything seems back to normal, the last connection that failed is now OK.