Qlik Community

Ask a Question

Connectivity & Data Prep

Discussion board where members can learn more about Qlik Sense Data Connectivity.

Announcements
Become an analytics expert with Qlik's new 15 week course: Applied Data Analytics using Qlik Sense. READ MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Special characters on Excel

Hi,

Im trying to load an excel file with special characters in fieldnames and possible values but QSense doesn't recognize it and gets trunk it

For example:

Selecting data generates the following code

LOAD

    Service,

    "SA2505 Site Name",

    "SA2525 City",

    "SA2535 Region",

    "SA2540 Estado",

    o,                           -> It should be SA4508 Dueño

    SBE_EP,

    SBE_NTW,

    "SBE_Tipo de Servicio",

    "SBE_Sub Servicio",

    "O)"                       -> It should be SBE_Planeamiento Mensual Cliente (AÑO)

     .

The same is happening in values.

Any help on getting through this? I've created an ODBC connector for each file but is very annoying

Many thanks.

11 Replies
marcus_sommer
MVP & Luminary
MVP & Luminary

What happens if you used: load * from ExcelFile; ?

- Marcus

Not applicable
Author

Hi Marcus,

Nothing happens, I mean is the same...

marcus_sommer
MVP & Luminary
MVP & Luminary

If possible try to load the excel as flat-file otherwise you need adjustments to the used charset within the driver or maybe a different one, see: LIB CONNECT TO odbc Codepage is not work.

- Marcus

Not applicable
Author

Marcus, how can I do to load file as flat-file?

marcus_sommer
MVP & Luminary
MVP & Luminary

Here are many resources for data-loading (and other stuff):

https://community.qlik.com/docs/DOC-6932#dataloading

- Marcus

Not applicable
Author

I prefer to avoid loading data by ODBC. Is there any place to configure character encoding, I mean UTF,Unicode,etc. because I think that this is the problem.

loadexcel.jpg

marcus_sommer
MVP & Luminary
MVP & Luminary

I don't think that there is a possibility to adjust the excel flatfile-load in opposite to a odbc-load.

Alternatives might be to change the OS region-settings (see here what is meant: Search - But what shall you find?) or to open the excel and copy or write the content (manually or with any macro-stuff) into another file-format like csv.

- Marcus

Not applicable
Author

I tried changing OS region-settings but doesn't work. If I copy the content manually to another excel it works but is a little bit annoying to final user.

ArnadoSandoval
Specialist II
Specialist II

Hi Damian

It seems your problem is with the Spanish version of Qlik Sense you are using, or a translation glitch with yours, as I tried without any drama using the English version (downloaded a couple of weeks ago), take a look at the screenshot below; my XL file has a column named DUEÑO and data using the ñ character.

I even tried your column name: "SBE_Planeamiento Mensual Cliente (AÑO)"

QVC-2016-11-21.png

Arnaldo Sandoval
A journey of a thousand miles begins with a single step.