Skip to main content
cancel
Showing results for 
Search instead for 
Did you mean: 
cjmckenna
Partner - Contributor II
Partner - Contributor II

Unable to connect to SQL Server using "Microsoft SQL Server" connection

We recently updated our database server to only use TLS 1.2. When we did that, our existing OLEDB connectors to Microsoft SQL Server stopped working. After looking into this, it looks like the OLEDB drivers do not support TLS 1.2, so I am trying to change these connections over to the MSOLEDBSQL version of this connection. However for the life of me, I cannot get this connection to work. I am able to connect just fine using SSMS, and the old OLEDB connectors worked fine until we disabled TLS 1.2. However I am getting a "cannot find server" generic error when creating the connection with the Microsoft SQL Server connection. 

I did some digging around and found that our DB server is using dynamic ports, so I tried specifying the same port:TCPConfig.png

 Here is what my MS SQL Server connection looks like:

MSConfig.png

 

I'm out of ideas, any help would be appreciated!

5 Replies
bsullivan28
Partner - Contributor
Partner - Contributor

Were you able to find a solution?

MChapp
Contributor
Contributor

Any updates on this issue?  We are currently experiencing a connectivity issue to Microsoft SQL Server after the June 2020 SR3 upgrade 

Sera
Contributor III
Contributor III

We are experiencing the same problems, after June 2020 SR3 update... 

tvisha
Creator II
Creator II

Any updates on this. I am facing the same issue. Thanks,

PadmaPriya
Support
Support

Hello @tvisha 

 

May I know what is the error you are facing?
Do you have TLS 1.1 or 1.2 enabled?
Have you enabled ipv4 and are you using static default port 1433 or dynamic port?
In services.msc please check the service account of SQL Server.

 

Thanks,

Padma Priya

Help users find answers! Don't forget to mark a solution that worked for you! If already marked, give it a thumbs up!