Skip to main content

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

QlikWorld 2023, a live, in-person thrill ride. April 17 - 20, 2023, in Las Vegas! REGISTER TODAY
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Connection to the Qlik Sense engine failed for unspecified reasons

I have one single user who is not able to access any apps due to the "Connection to the Qlik Sense engine failed for unspecified reasons" error. He is able to log in successfully, but as soon as he lands on the hub page he gets this message and is unable to proceed. This is the only user in our deployment that has ever reported this issue. I have not been able to replicate the error circumstances myself. The user works/lives remote so it's been a little challenging to troubleshoot this, but I have read and tried suggestions from several other posts on the issue. 


The problem is I'm not finding anyone else who has experienced this issue for just one user only. Does anyone have any ideas for me?


I'm on Sense Feb 2019, I have the server address white listed in QMC, and all recommended ports open in my firewall rules. The user is on Windows 7/Google Chrome. 

6 Replies
Creator II
Creator II

As it is isolated to 1 user, I would try deleting that user in the QMC and see what happens when they come back in.

Partner - Creator II
Partner - Creator II

I have a similar problem: Same situation, same message as soon as the hub opens up.

Sense Feb 19, my user works from chrome and Safari on a Mac, but not from an iphone.

I made sure the phone has the latest ios, Safari and Chrome, but no luck.

Oh, and the QMC works just fine on the phone.

Not applicable

When this happens for one user, I agree, it can be a struggle to figure it out. Nonetheless, checkout this article as it is often the solution for the broad case. 

Consider changing their location using an RDP session to a known working browser on another machine. From there you can rule out the user itself and divide an conquer what variables remain (VPN, Browser, Proxy settings in a browser, etc...).  

The development tools (network and console) on the browser could also lead to clues as to why it is failing.

Partner - Creator II
Partner - Creator II

Here is what worked for us:

Used http: instead of https: to access the hub from the iPhone.

In QMC, made sure "Allow HTTP" is turned on in the Ports section of the Central Proxy properties.

Since then, we've had no more issues.

Hope this helps!

Not applicable

If HTTP works for your iPhone, this would be correct for a scenario where the Central Node does not contain the Apple Certified certificates (configured in the QMC proxy security thumbprint). One's IT support should be contacted to add these  Apple Certified certificates in the central node.

A good way to troubleshoot the connection is to use HTTP vs HTTPS, if HTTP works it is likely lack of or wrong certificates. 



I have similar issue. We used to have SSL for https access but were told to remove as it is for internal use.

We have the server hostname whitelisted in virtual proxy earlier.

We did enable HTTP but the result is :

1. QMC using HTTP & HTTPS both ok.

2. Hub using HTTPS ok.

3. Hub using HTTP have the able mentioned error.

We checked and Port 80 is not blocked.

Any advise?