Skip to main content
Announcements
YOUR OPINION MATTERS! Please take the Qlik Experience survey you received via email. Survey ends June 14.
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

Issue with default http 80 port

Hi,

We experience an issue when installing a Qlik Sense 2.1.1 on a Windows Server 2012 R2.

Basically, all is working fine with HTTPS.

In HTTP mode, all is working if we don’t use 80 port. We try 82 and all is ok.

More elements that we found during analysis:

  • This append only with the public IP, not when we try http on 80 with the internal name of the server.
  • Nothing else is bind to 80 on server
  • The issue seems to be linked to web socket connection that is closed too early (and too brutally) : we analyze the web socket frames with Fiddler, both with 80 and 82 port, and web socket on 80 is « close », sometimes without getting all the response.

Moreover, firefox devtools tell us that websocket connection was interrupted :

Capture.PNG

Did someone already experience this issue and found a solution ?

I've seen some question/answer with the same problem but the discussion stop when server is working on another port, but we want it to work on 80.

Regards,

Gurvan

1 Reply
korsikov
Partner - Specialist III
Partner - Specialist III

i'm use Sense server on 81 port http. http://bi.prozorro.org:81/hub

And yes, I also have a similar error occurs. But I can not understand the law of manifestation.

connection may break off immediately after connection and after 30 or 60 minutes.