Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
QlikWorld 2022, LIVE in Denver CO., May 16-19, 2022. REGISTER NOW TO RECEIVE EARLY BIRD PRICING
cancel
Showing results for 
Search instead for 
Did you mean: 
dferreirogft
Contributor III
Contributor III

Problem distributing certificates to rim node

Hi.

We're trying to configure a rim node on a qliksense server following the tutorials found but we are stuck in one of the steps.

We succesfully installed the qliksense server on the rim server.  Once installed, we took a look to the Repository logs and says: 

Starting certificate password verification webservice...

Setup service initialized with 2 available methods

Took a look into the proxy logs also and no errors nor warnings.

 

When we go to the central node and try to add the rim node we get the following error:

dferreirogft_1-1634193731646.png

We searched all the topics in the community but no solution worked for this problem.

We opened the following ports in both slave and master servers and still don't work:

dferreirogft_2-1634193819666.png

 

Can anyone give us an advice?

 

Thanks in advance.

Labels (1)
  • Other

1 Solution

Accepted Solutions
Sooraj_Suresh
Support
Support

Hello please make sure port 4432 is listening as it's used to connect to repository database.

Make sure the port 4444 is listening on RIM node then the certificate distribution will be successful.

If there is a firewall please turn of it and try the certificate distribution.

View solution in original post

14 Replies
sorrakis01
Specialist
Specialist

Hi,

I'm interested too, anyone can help us?

Thanks

sorrakis01
Specialist
Specialist

Come on community any idea? 😅

Thanks Best Wishes

Maria_Halley
Support
Support

Can you check with the utility tool so that all ports are open.

https://community.qlik.com/t5/Knowledge/Qlik-Sense-Utility-Functions-and-Features/ta-p/1711747

 

 

BILeadtech
Contributor II
Contributor II

Hi. 

I cannot see where in the tool I can check for the opened ports:

BILeadtech_0-1634290234999.png

 

Maria_Halley
Support
Support

If you connect to the db and choose connection checker, Does that not check ports (I can't log in right now and check)

BILeadtech
Contributor II
Contributor II

you are right.  We checked and we have a loot of ports saying : "could not establish connection because the host actively refused". Witch could be the problem?

Sooraj_Suresh
Support
Support

@BILeadtech @dferreirogft 

Please make sure central node and RIM node are reachable from both sides using ping. 

Then check if the RIM node is able to connect to database and also make sure the ports 4444(QRS certificate) and 4432(QRD)- inboundfrom RIM node are listening. 

Make sure if the firewall is running then either disable it or add exceptions to the ports in firewall. You can refer to the ports used in communication in the below link under "Minimum ports used for communication in multi-node sites

(https://help.qlik.com/en-US/sense-admin/August2021/Subsystems/DeployAdministerQSE/Content/Sense_Depl...

 

Best Regards

Sooraj Suresh

BILeadtech
Contributor II
Contributor II

Hi, Both sites are reachable thought ping. The port 4444 is listening but 4432 is not. Which service makes port 4432 listen?

BILeadtech
Contributor II
Contributor II

On the other hand, when I configure the rim node on the central node and I get the error. I tried to access the URL the server sais cannot access and I can reach it, but with some kind of an error:

BILeadtech_0-1634534285634.png