Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

QlikWorld online is next week! REGISTER NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor III
Contributor III

Problem distributing certificates to rim node


We're trying to configure a rim node on a qliksense server following the tutorials found but we are stuck in one of the steps.

We succesfully installed the qliksense server on the rim server.  Once installed, we took a look to the Repository logs and says: 

Starting certificate password verification webservice...

Setup service initialized with 2 available methods

Took a look into the proxy logs also and no errors nor warnings.


When we go to the central node and try to add the rim node we get the following error:


We searched all the topics in the community but no solution worked for this problem.

We opened the following ports in both slave and master servers and still don't work:



Can anyone give us an advice?


Thanks in advance.

Labels (1)
  • Other

14 Replies

Hello please make sure port 4432 is listening as it's used to connect to repository database.

Make sure the port 4444 is listening on RIM node then the certificate distribution will be successful.

If there is a firewall please turn of it and try the certificate distribution.


I see that you are opening the URL so is that URL being accessed from RIM node browser?? And also instead of IP please try with the hostname or FQDN.

Contributor II
Contributor II

Hi, No, the url opened is opened on the central node. 

The port 4443 should be listening on the central node right? As it is the RIM node who connects to the central one. 

If so, the port is actively listen: 



On the other hand, when installing the RIM node and configure the repository of the central node in there, no error is being reported. But when the installation ends and I check the repository lisgs on the RIM node I see messages like this:





Once the RIM node has been added in QMC under nodes then select to distribute certificates to RIM node it will show a dialog box with URL and password.

You need to enter the URL in RIM node and then Enter the password for successful node registration.

Also port 4444 and 4432 should be listening on RIM node aswell.

Contributor II
Contributor II

Yes, is in this step where I find the error shared.

Tried to reinstall the RIM node and in a fresh install without errors the port 4444 si listening while 4432 is not. Do you knwo what could be the cause?