Qlik Community

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
IMPORTANT security patches for GeoAnalytics Server available to download: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Not applicable

QMC Greyed out when using virtual proxy

Hi All,

I have a user which I have granted RootAdmin privileges. When I log into qmc normally without the virtual proxy https:///{servername}/qmc, the user is able to access all the qmc features. However, when I login via the virtual proxy url https:///{servername}/{virtualproxy}/qmc, I am able to login and see the qmc but I cannot access any of the features.


Any ideas?

Regards,

Alex Watts

1 Solution

Accepted Solutions
Not applicable
Author

I fixed my problem, it was an issue with the user not having RootAdmin role, but with a twist. My problem was, when I logged into using the virtual proxy, it created a completely new user. I assume that's normal Qlik functionality, now because I was logged in as that "new" user account, it didn't have RootAdmin privileges. Once I assigned it to the "new" user account, then it all worked fine.

View solution in original post

5 Replies
Not applicable
Author

Hi Alex,

Can you please explain what do you mean by you cannot see any of the feature , Is it appearing like you have no access to QMC.

See when you are saying User is  Root Admin , So it mean , your user will see all the features enable, but here by your words , you are saying you can login in , It means your DNS is configured fine ,

Did you done that part where , you need to add your soft domain address to virtual proxies=> central proxy =>advanced => Host white list and enable the http  option. please do it if you didn't.

Please let me know if you are still facing any issue

Not applicable
Author

Hi,

Thanks for the reply. When I say I can't access the features I mean, I can see the QMC screen but cannot access any of the features, see below. The user in question does have the RootAdmin role assigned

2016-08-18 09_39_20-Qlik Management Console.png

Without the virtual proxy prefix, I can access the qmc with the same user, see below

2016-08-18 09_45_18-Qlik Management Console.png

I have also added the qlik host to the white list. Which is why I'm not sure what is going on.


FYI I modified my C:\Windows\System32\drivers\etc\host file to manually add qlikproduction based on AWS EC2 public IP address

Not applicable
Author

Can you show me a snapshot where you have assigned role to this user,  Ideally it should behave like it, One more question , which version you have installed , Is it 3.0.1 if not please upgrade to it.

Not applicable
Author

I fixed my problem, it was an issue with the user not having RootAdmin role, but with a twist. My problem was, when I logged into using the virtual proxy, it created a completely new user. I assume that's normal Qlik functionality, now because I was logged in as that "new" user account, it didn't have RootAdmin privileges. Once I assigned it to the "new" user account, then it all worked fine.

Not applicable
Author

I do have to ask, when I logged in via the virtual proxy, it created a new user. Is that common Qlik functionality? I have 2 users with the same username but different User Directory values. I am using 2.0.7 Qlik Sense btw and do not have any plans to upgrade in the near future