Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Qlik Insider - Maximize your investment, Join this webinar, May 26th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
andrea_cignoni
Partner
Partner

Qlik Sense - connection lost with mobile

Hi to all,

this is my Qlik Sense frist installation.

everything is fine, on desktop pc works!!

But on mobile (ios, android, safari or chrome) I have always the same error.

Foto 07-11-14 11 39 49.png

Connection lost after login page.

I have allocated 4 token 2 login access and 2 user access

I have added the SERVER address(IP,DNS) on white list of proxy

Immagine.png

is there someone in same situation??

thanks for replies!!

Andrea

1 Solution

Accepted Solutions
Vinay_Kapoor
Employee
Employee

Hi,

EDIT: I just noticed that you already tried http:// brain dead of me to not read the whole thread. I'll leave this post here anyway as complimentary information to future visitors.

Looks like you are using SSL (https) for your mobile access. Is your SSL certificate signed  by a trusted authority or are you using the stock certificate shipped with Qlik Sense? If you do not use a signed trusted certificate, then iOS8 will block ALL ACCESS to your server. There is no way around it, it's a iOS security feature.

Enable http on your QMC and then access Qlik sense from your mobile device using pure http, or install a signed root certificate on your http server.

regards,

VInay

View solution in original post

7 Replies
Michael_Tarallo
Employee
Employee

Hi Andrea - can you send us your log files found here on the server:

C:\ProgramData\Qlik\Sense\Log\Proxy

C:\ProgramData\Qlik\Sense\Log\Repository

C:\ProgramData\Qlik\Sense\Log\Engine

If you can .zip them up and attach to the case we can take a look.

I have seen this before and it could be related to a few things.

  • What browser are you using on the mobile device?
    • At the moment only Safari is supported on the iPhone
  • If using iOS Safari - are you using Private Browsing? - IF so turn that off.
  • What version of iOS are you using?
  • It may be a certificate / security communication issue
    • Can you go to the QMC Start-> Proxies -> Edit the Central Proxy -> check HTTP and try to access machine name / IP WITHOUT HTTPS - and note the results.

We'll get to the bottom of this, we just need to troubleshoot a bit.

Regards,

Mike

Regards,
Mike Tarallo
Qlik
andrea_cignoni
Partner
Partner
Author

Hi Michael,

i use iOS 8.1, i don't use Private Browsing on Safari.

i have checked HTTP and i use this url:

http://[my ip]/hub

but result is only a blank page. (both on PC and Mobile)

Vinay_Kapoor
Employee
Employee

Hi,

EDIT: I just noticed that you already tried http:// brain dead of me to not read the whole thread. I'll leave this post here anyway as complimentary information to future visitors.

Looks like you are using SSL (https) for your mobile access. Is your SSL certificate signed  by a trusted authority or are you using the stock certificate shipped with Qlik Sense? If you do not use a signed trusted certificate, then iOS8 will block ALL ACCESS to your server. There is no way around it, it's a iOS security feature.

Enable http on your QMC and then access Qlik sense from your mobile device using pure http, or install a signed root certificate on your http server.

regards,

VInay

View solution in original post

andrea_cignoni
Partner
Partner
Author

I solve the problem!!!!

The solution is use HTTP but, i change port 80 to 82, now the URL is:

http://[my ip]:82/hub

it works on desktop and mobile!!

regards

Andrea

Vinay_Kapoor
Employee
Employee

Excellent.

You may want to run a port scanner as it looks like your port 80 is being hogged by another service.

/Vinay

hernan_leon
Contributor II
Contributor II

Hello guys,

I have issues currently accessing the hub from mobile devices, I have followed your advises in this thread but it's not been successful so far, if you can have a look at it I'd really appreciate it:

http://community.qlik.com/message/706069#706069

Thanks a lot!

borisman
Creator III
Creator III

what helped me was adding our domain to "white list" on the QMC - it is under virtual proxy