Qlik Community

Ask a Question

Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

Announcements
Our May 2021 end-to-end product release from Data Integration to Data Analytics is out! READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
s_lobunko
Contributor II
Contributor II

SSO header setup

HI 

I have some problem with SSO setups.  I tried to make some virtual proxies, with a static header and dynamic header.  But I can't follow on my hub link. 

When I  try to follow on the link with static header name hub doesn't load, I see the only endless page loading. 

I use following settings in the virtual proxy(static header😞 

anonymous access mode =   Allow anonymous  user 

Authentication mode = Header authentication static user directory

header authentification header name = MyHeader

header authentification static user directory = MyDoaminUserDirectory 

I tried to catch errors using Fiddler and I see that I go through all the stages. I am authenticated to the MSS and the link to the hub. But in Fiddler logs  "Fiddler.network.gateway.connect to 127.0.0.1 Connection is not established, because destination computer rejected connection request".  Maybe I'm doing something wrong? 

When I  try to follow on the link with the dynamic header I get the page with error 400 code "Header authentification: The incoming header does not match the following pattern $ud\\$id  

I use the following settings in the virtual proxy(static header😞 

anonymous access mode =   Allow anonymous  user 

Authentication mode = Header authentication dynamic user directory

header authentification header name = MyHeader

header authentification static user directory = $ud\\$id 

I don't understand the principle settings dynamic header. 

What are $id and $ud  Are these variables? Where to specify their meaning? 

if I try following to link mycompany.domain.com/111 I get 404 error This means that the rule on SSO is fulfilled. 

I don't understand when I wrong?

We are used to multiple domain infrastructure maybe some special settings are needed for this?

As an SSO we use Oracle Access Manager

 

Please help me

P.S. Sorry for my bad English. I have tried

 

Labels (1)
0 Replies