Skip to main content
Announcements
Live today at 11 AM ET. Get your questions about Qlik Connect answered, or just listen in. SIGN UP NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
asafrian1700127126
Contributor II
Contributor II

Heap space, garbage collection and Error occurred during initialization of VM Talend

I can't run the job the following error appearsI can't run the job the following error appears

asafrian1700127126_2-1711608714175.png

asafrian1700127126_0-1711607754733.png

Error: Could not create the Java Virtual Machine.
Error: A fatal exception has occurred. Program will exit.
Error occurred during initialization of VM
Unable to allocate tables for parallel garbage collection for the requested heap size.
Job EXPORT_TO_SKK_VIEW ended at 13:08 28/03/2024. [exit code=1]

 

Following are the memory settings for the VM

asafrian1700127126_1-1711607892613.png

 

then suddenly a garbage collection appears as follows

asafrian1700127126_0-1711609206377.png

So what is garbage collection?

 

What do I have to do?
I have added xms and xmx but the same error
How do I delete the trash that causes memory to become full like this?

 

Labels (3)
5 Replies
MahiwalVinit
Creator
Creator

What is your studio version ? 
How much JVM has been given in studio's .ini file ? Also check your system's memory usage is it sufficiently free to allocate 1G ?

asafrian1700127126
Contributor II
Contributor II
Author

I use TOS_ESB-win-x86_64 "Talend Open Studio for ESB" Version: 5.6.3 Build id: V5.6.3_20160127_1448 and JAVA_VERSION="1.7.0"

.ini file :

-vmargs
-Xms64m
-Xmx1536m
-XX:MaxPermSize=512m
-Dfile.encoding=UTF-8

 

The memory allocation:

asafrian1700127126_0-1712030491763.png

 

 

MahiwalVinit
Creator
Creator

Please try increasing -Xmx1536m to -Xmx2024m in .ini file. Also make sure you have 50% system memory available to run Studio, 87% is high memory usage

asafrian1700127126
Contributor II
Contributor II
Author

Hi, I changed the jvm arguments for each job from -xms256mb -xmx1024mb to -xms512mb -xmx2048mb but still experienced the same error (even though the .ini file had not been changed).
If you only change the .ini file, will it only affect Talend performance in general, such as processing speed, and not affect the performance of each job being run, or what?

jlolling
Creator
Creator

Try to set the job jvm option to

-Xmx2G

and of course set the studio memory in the ini file also at least to 

-Xmx4G