Qlik Community

Ask a Question

GeoAnalytics

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
Support Cases coming to Qlik Community Oct. 4! Start chats, open cases, explore resources: READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Matsa
Creator
Creator

How could I connect to our arcgismap server and use its maps via Idevio GeoAnalytics connector?

Hello  experts,

We are using Qlikview 11 and IdevioGeoAnalytics.

we want to use our map from arcgismap server via Idevio GeoAnalytics connector.

as you can see bellow I selected 'Load' as Operation and File based geo dataset, I put key field and I put our 

Geojson query path as URL!

But It gave me an error :

clipboard_image_0.png

it seems the URL is not correct, what should I put as URL?

clipboard_image_0.png

I appreciate any help on this matter.

Regards

Matsa

Labels (1)
5 Replies
Patric_Nordstrom
Employee
Employee

The url should return the actual geojson geometries.

Test in a browser and check if the response is valid geojson, by pasting the result in http://geojson.io/ or save and open in QGIS.

Thanks,

Patric

Matsa
Creator
Creator
Author

Thanks @Patric_Nordstrom  for the guide,

on  http://geojson.io/ It does not work.

 here are the steps that I did:

  • open http://geojson.io/ 
  • delete the content of  JSON (right window)
  • I pasted a part of  our geojson(I could not paste all the file, I pasted a part of it)
  • save it as geoJson 
  • I opened it and I faced with this error:
  • clipboard_image_1.png

Infact the Json code is not saved( because I see the default code on right window)
But the point is that since this URL works in geodata layer it is correct, don't you think so?

Thanks,

Matsa 

Patric_Nordstrom
Employee
Employee

Yes, geojson.io can only handle data in EPSG:4326 so your data is fine.

Thanks,

Patric

Matsa
Creator
Creator
Author

Thank you @Patric_Nordstrom , 

So what could be a reason of the error when I use Connector ?
Thanks.

Patric_Nordstrom
Employee
Employee

Is the arcgis server internal? Then you need to install and use QGA plus.

Thanks, Patric