Skip to main content

GeoAnalytics

Discussion Board for collaboration regarding Qlik GeoAnalytics.

Announcements
QlikWorld 2023, a live, in-person thrill ride. Save $300 before February 6: REGISTER NOW!
cancel
Showing results for 
Search instead for 
Did you mean: 
mark_costa
Partner - Creator II
Partner - Creator II

How to format numbers in Info Bubble?

Good day,

I need to display a number in % in Info Bubble.

Can someone help me on this?

Regards,

Mark Costa

9 Replies
zhadrakas
Specialist II
Specialist II

Hello Mark,

try like this:

num(YourValue, '0%')

regards

tim

mark_costa
Partner - Creator II
Partner - Creator II
Author

Hi Tim,

Thank you for your reply.

I already tried that in my Measures (Expressions) - among other things - in different ways, none have worked:
1. Adding a measure and set its Number formatting as Number and in %
2. Adding the Num() in the measure Expression (as you suggested) plus the formatting in #1

3. Adding the Num() in the measure Expression (as you suggested) plus Number formatting to Auto

4. All above but using Master Measures

5. All above and forcing the Info Bubble to format only the second value displayed

Looks like Info Bubble does not recognize the format defined in the Measures and this is kind embarrassing for a tool that expensive.

Note: the Extension that I am using is the Area Layer.

Regards,

Mark Costa

zhadrakas
Specialist II
Specialist II

did you try to concatenate the number and %

=num(YourNumber) & '%'

or something like

text(YourNumer & '%')

regards

tim

mark_costa
Partner - Creator II
Partner - Creator II
Author

Just tried both ways, no luck.

zhadrakas
Specialist II
Specialist II

you could also try HTML code in this info Bubble like

<div> YourNumer & '%'  </div>

rajan_1989
Contributor III
Contributor III

In the info bubble settings , just uncheck the 'format numbers' checkbox and it should work

mark_costa
Partner - Creator II
Partner - Creator II
Author

Hi Rajan,

I tried this already and it also does not work.
I think I will have to create a custom HTML code as Tim suggested. I'm trying to avoid that but I think it is the only way.

Thank you,

Mark Costa

Jonas_Linden1
Support
Support

mark.costa

Hi Mark,

If you add a blank space before or after the % it shall work@: & ' %'

To be able to add an expression to an info bubble you need to add a measure under Location ID. Then you can customize your info bubble with an expression (fx). See pictures before and after adding a measure below.

So add a measure to your Area layer if not already done and then you can open the expression editor (fx) under Appearance/Info Bubble.

Hope it helps,

Jonas

Qlik Sense InfoBubble.pngQlik Sense InfoBubble2.png

paulo_pinto
Contributor
Contributor

Yes, it seems that num() formula does not work.
Workaround:
Round((expr)*100,0.1) & '%'

Hope it works for you!