Skip to main content
Announcements
See what Drew Clarke has to say about the Qlik Talend Cloud launch! READ THE BLOG
cancel
Showing results for 
Search instead for 
Did you mean: 
iffahjo
Partner - Contributor II
Partner - Contributor II

Configuring the Bot Channel Service for Microsoft Teams not working

Hi,
I have followed all the steps for configuring the Insight Advisor Chat for Microsoft Teams. I followed the official documentation of Qlik. There was no error or any ambiguity in steps. However, when I ask question on Teams to the Insight Advisor Chat, there is no response. Furthermore, there is no log on Azure bot or any way to debug. I need help in debugging the process as I don't know where exactly is the problem. 

I followed these documents:

Configuring Qlik Insight Advisor Chat in Qlik Sense Enterprise on Windows:
https://help.qlik.com/en-US/sense-admin/August2023/Subsystems/DeployAdministerQSE/Content/Sense_Depl... 

Configuring Qlik Insight Advisor Chat for external channels:
https://help.qlik.com/en-US/sense-admin/August2023/Subsystems/DeployAdministerQSE/Content/Sense_Depl... 

Creating a Microsoft Azure Bot Service:
https://help.qlik.com/en-US/sense-admin/August2023/Subsystems/DeployAdministerQSE/Content/Sense_Depl... 

Configuring the communication channel for Microsoft Teams:
https://help.qlik.com/en-US/sense-admin/August2023/Subsystems/DeployAdministerQSE/Content/Sense_Depl... 

Configuring the Bot Channel Service: https://help.qlik.com/en-US/sense-admin/August2023/Subsystems/DeployAdministerQSE/Content/Sense_Depl... 

 

The Virtual proxy is set in the Qlik with the JWT certificate.

Azure bot is configured (I have used secret key as password for the bot).

Have configured the communication channel as Teams and configured the bot channel services exactly as shown in the guideline. 
Kindly let me know how to solve this.
Thanks.

Labels (1)
7 Replies
Mario_De_Felipe
Luminary
Luminary

Hi @iffahjo! I've followed @Michael_Tarallo 's instructions and worked for me:

https://www.youtube.com/watch?app=desktop&v=WJHDPK7zc_M&feature=youtu.be#bottom-sheet 

Hope it helps. Kind regards

iffahjo
Partner - Contributor II
Partner - Contributor II
Author

Hi @Mario_De_Felipe !

Thank you for your response.

I've watched the youtube video but it only shows the tutorial for Qlik Sense SaaS/Cloud.

In my case, I want to setup the Bot Channel Service on Qlik Sense Enterprise on Windows
that needs to create Azure Bot to connect to Ms Teams as the attached link.

 

Nasser_Bumpus
Employee
Employee

Hello @iffahjo  - Reach out to support. They will ask to enable audit logs and review the configuration of the azure bot. A common challenge that I have seen is the messaging endpoint being blocked by App gateway, but support will help resolve. Thanks!

iffahjo
Partner - Contributor II
Partner - Contributor II
Author

Hi @Nasser_Bumpus !

Thank you for your response. I already reached out to support but they suggest to raise the question on community.

Here's my Azure Bot configuration:

iffahjo_0-1700550601022.png

When I test the messaging endpoint on browser ( https://abs-iffah/api/messages ), it shows
"Cannot GET /api/messages"

Here is the BotChannelService logs:

iffahjo_1-1700550677326.png

Do you know any solution for this?

Thanks!

 

Nasser_Bumpus
Employee
Employee

This is helpful. Please send me a direct message with an email to contact you at and I will follow up with one of my resources.

iffahjo
Partner - Contributor II
Partner - Contributor II
Author

Hi @Nasser_Bumpus !

I just sent direct message to you.

Thank you for your help!

rusnakpe
Contributor III
Contributor III

Hi @iffahjo / @Nasser_Bumpus were you able to solve that issue? I would need the same. Thanks!