Skip to main content
Announcements
July 15, NEW Customer Portal: Initial launch will improve how you submit Support Cases. IMPORTANT DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
Kwokwha
Partner - Contributor II
Partner - Contributor II

Import of an app to Qlik Sense SaaS using REST API results in 403 forbidden when using autoreplace as mode

Hi all,

we're trying to upload an qvf file to Qlik Sense SaaS using the REST API. According to the documentation [Apps | Qlik Developer Portal] there are two modes: NEW and AUTOREPLACE. When using mode NEW, everything is fine and we got a 200 OK and the file is shown in Qlik Sense SaaS. However using mode AUTOREPLACE, the result is 403 forbidden. I checked the user and it has all the permissions set. Am I  forgetting something? 

Labels (3)
4 Replies
NadiaB
Support
Support

Hi @Kwokwha 

 

By any chance could the following details be provided?

 

When its said "the user has the privileges set" What privileges are those? Could we listed?

Is the user attempting to use the API method owns the app?

Is the app in a personal space? Shared Space ? Managed Space? 

If in Shared or Managed space what are the privileges the user attempting to replace the app has in that space?

Thank you in advance!

Don't forget to mark as "Solution Accepted" the comment that resolves the question/issue. #ngm
Aurelien_Martinez
Partner - Specialist II
Partner - Specialist II

Hi,

I have done a script like that and I was confronted to the same porblem. I workround I found (with Qlik Support help) is:

 

1. import app in my personal space : 

qlik app import --file $appPath/$appFileName --mode new --name $appName -q

2. publish and replace like : 

app publish update $appId --data "source" --targetId $publishId --checkOriginAppId=false

 

Aurélien

Help users find answers! Don't forget to mark a solution that worked for you!
Kwokwha
Partner - Contributor II
Partner - Contributor II
Author

Hi @NadiaB ,

thanx for your reply.

I'm trying to import a qvf file into the personal space. The user is actually the tenant admin , but does also have the roles of Analytics Admin, Data Admin, Data Space Creator, Developer, Managed Space Creator, Shared Space Creator.

I'm using the rest api to accomplice this. As described in the documentation I'm using the endpoint: <tenant url>/api/v1/apps/import. I also added query parameter mode (AUTOREPLACE).

When I use NEW as mode, then there's no problem. I receive 200 OK response. But when I use AUTOREPLACE as mode I get a 403 forbidden. Our requirements is to use the AUTOREPLACE mode.

It looks like I'm not allowed to use AUTOREPLACE. But I don't know why.

 

Kwokwha
Partner - Contributor II
Partner - Contributor II
Author

Hi @Aurelien_Martinez ,

thanx for your reply. I'm using the rest api to accomplice this. But still your solution could work. I'll have a try.