Qlik Community

Ask a Question

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Our May 2021 end-to-end product release from Data Integration to Data Analytics is out! READ DETAILS
cancel
Showing results for 
Search instead for 
Did you mean: 
hartmoli
Partner
Partner

Mashup Issue, Fullscreen View - Mouseover doesnt work

Hi community,

I've encountered a problem while trying to create a fullscreen view of a object in a qlik sense mashup. The situation is following: i have several objects (bar-chart, pie chart, tables) displaying on one page. I've created an opportunity to make these objects fullscreen, therefore im ussing some css sytles (position: fixed, width:100%, height:100%, top: 0;, right: 0; , left:0, bottom:0;). The objects expand perfectly fullscreen, but unfortunately the mouse-over function that should display the figure dosent appear in fullscreen mode. After spending a lot of time in testing, i discovered that the problem is based on the css setting position:fixed. Unfortunately, i'm not able to solve this issue. Somebody has an idea how to fix this issue or has encountered the same issue and found an workaround?

Thanks in advance for any helps.

qlikcom.PNG

1 Solution

Accepted Solutions
add
Employee
Employee

Hello,

To me it sounds like a z-index issue, do you have a z-index value on the element you do 'position: fixed'?


Regards,

Ann-Louise

View solution in original post

4 Replies
add
Employee
Employee

Hello,

To me it sounds like a z-index issue, do you have a z-index value on the element you do 'position: fixed'?


Regards,

Ann-Louise

View solution in original post

hartmoli
Partner
Partner
Author

Hi  Ann-Louise,

Thanks for your reply to my issue.

Yes I do, there is z-index value. Here are all my css properties for the full-screen:

.panel.widget-fullscreen {

  display: block;

  z-index: 9999;

  position: fixed;

  width: 100%;

  height: 100%;

  top: 0;

  right: 0;

  left: 0;

  bottom: 0;

  overflow-y: auto;

}

Thank you for your further help.

Regards Oli

add
Employee
Employee

Try to lower the z-index, start with 100 and then lower it more if needed.

Regards,

Ann-Louise

hartmoli
Partner
Partner
Author

Indeed it was the z-index properties. I played around a little bit, and found out that the z-index value of the qlik mouse-over object is determinated something around 1010-1020.

I simply set the z-index value of my fullscreen object lower than 1010 and everything works perfect. Thank you Ann-Louise for the right hint