Qlik Community

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

Announcements
Customer & Partners, DEC. 9, 11 AM ET: Qlik Product & Strategy Roadmap Session: Data Analytics REGISTER NOW
cancel
Showing results for 
Search instead for 
Did you mean: 
jescartin
Contributor
Contributor

Trouble copying an App

Hello everybody,

I'm not being able of copying an app from the engine API. I need to be able to override an App content (sheets, variables, etc) with the content of a different App.

That is, if I have app A, whose id is xxx-xxx-xxx and app B, whose id is yyy-yyy-yyy, I need to be able to pass variables and sheets from B to A, but keeping A's id xxx-xxx-xxx and keeping the data previously load.

I pass the following request:

{"handle": -1,"method": "CopyApp","params": {"qTargetAppId": "1469f966-ad1c-4e6e-807a-c712857429b3",

"qSrcAppId": "22e7838f-f734-4eac-92e7-643dc84a8d28","qIds": ["mXgZa"]}}

Where "1469..." is the target app, "22e..." is the source app and "mXgZa" is the id of the sheet contained in the source app that I want to copy into the target app. I get following error:

{

    "error": {

        "code": 9003,

        "message": "Resource not found",

        "parameter": "Engine ID not found"

    },

    "id": 0,

    "jsonrpc": "2.0"

}

The only thing I can do to get rid of the error is remove the content "mXgZa" from the qIds field. in that case I get sucess but of course, it does nothing.

As far as I understand, it should work since "mXgZa" is the identifier of the sheet. I have not been able so far to find out what is wrong there. I hope somebody can help me aorund here.

Thanks in advance!

11 Replies
bekahbeets
Creator
Creator

Yes, i have tried with 1 id, empty string for id, nothing where the id's go, and all the id's. Nothing works

bortolotti_carl
Partner
Partner

I got the same problem after update my qliksense to setember 2018 version... im very disappointed with qliksense sdk and qliksense/server... when my customers update your own qliksense server my apps stop because this problems... i believe that apis should have to maintain the compatibility between old versions...

When i inform an object id:

error_with_ids.PNG

When i do not inform an object id:

error_without_ids.PNG