Skip to main content

Integration, Extension & APIs

Discussion board where members can learn more about Integration, Extensions and API’s for Qlik Sense.

CUSTOMERS ONLY: Now accepting customer applications for the 2023 Luminary Program: SUBMIT NOW
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Where can I find qTableName for GetTableData?


According to the QlikSense Engine API documentation below the following method can be used to extract the data from a table.

GetTableData method

Retrieves the data of a specific table

This method uses a parameter called qTableName.I am unable to find anywhere in the QlikSense application or throught the engine API methods the name of the table to be used for this operation. Can anyone help?

GetTableData method ‒ Qlik Sense

I have tried using the method getObject using the qId of the table and this is all I get back. It does not contain the qTableName. Can anyone help?


    "jsonrpc": "2.0",

    "id": 32,

    "result": {

        "qReturn": {

            "qType": "GenericObject",

            "qHandle": 2,

            "qGenericType": "table",

            "qGenericId": "xnbSUQM"




2 Replies

It's the name of a table in the data model. You can fetch all available tables and their associated keys using the method GetTablesAndKeys method ‒ Qlik Sense

If you are looking to extract data then perhaps a Generic Object with a qHyperCubeDef defintion would be a better way as you then also can interact with the data more easily.

If you have more in-depth questions, feel free to come join us on slack and ask away in the engine-api channel. There is usually folks around to help out.

Contributor II
Contributor II

Hello Alexander,

Thank you for the quick reply.

I have tried the method you have suggested but this does not solve the problem.

1) GetTablesAndKeys method returns the information regarding the base tables that are part of the data model. Any Straight Tables that have been created in the front end in QlikSense are not returned by this function

2) The returned information by GetTablesAndKeys does not contain qTableName, it only contains qName like in the example below. When using GetTableData with the value of qName the respone is empty because the table is not matched.

"qName": "Global_KPIs_Act",

"qNoOfRows": 28,

I understand that there are different ways to extract data (such as qHyperCubeDef) but I believe in correct and accurate documentation.

Is it possible to provide a working example of how to use GetTableData for a user created Table in QlikSense?

Thank you for your suggestion of joining slack. I will do that!