Skip to main content
Announcements
NEW Customer Portal: Initial launch will improve how you submit Support Cases. FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
Gabo77
Contributor III
Contributor III

Problema con función Aggr

Gabo77_0-1690812752635.png

 Tengo este esquema de datos donde FechaInicio tiene la Fecha de la producción con Horas, Minutos y Segundos. Además, calculo el campo llamado Fecha, que se calcula usando Date(Floor(FechaInicio)) y a partir de ahí uso esa fecha para obtener el Año, Mes, Semana y demás campos de la tabla.

Gabo77_1-1690812778225.png

La tabla Sesión, representa una sesión de captura de producción desde la cuál en la tabla Detalle se captura cada una de las entradas de producción uno a uno por su Tipo de Detalle (Bueno [B], Malo [M], Retrabajo [R]). Se contabiliza sólo las entradas con B y R, por lo que, para calcular las toneladas de producción de cada Sesión, se Suman las entradas de Sesión de Tipo B y R y el resultado se multiplica por Netwgt del producto asociado a la sesión desde la tabla Products usando la siguiente fórmula: (Netwgt * Count({<Tipo={'B','R'}>} Tipo)) / 1000 (Se divide entre 1000 para obtener las toneladas) Esto se almacena en una variable llamada: vTonsProdXSesion

Gabo77_2-1690812819893.png

Con este esquema, si muestro las toneladas producidas por cada sesión (Con su ID único llamado IdIndicador) con su campo FechaInicio y el valor del campo Fecha se muestran las toneladas por sesión correctamente.

Gabo77_3-1690812840280.png

Ahora, quisiera mostrar la suma de las toneladas producidas para un día en particular, por lo que, a mi entender, uso la siguiente fórmula: Sum(Aggr($(vTonsProdXSesion), Fecha)) Según entiendo, estoy creando una tabla virtual que me debería permitir sumar todas las sesiones de una fecha en particular (Del campo Fecha sin horas, minutos y segundos) pero, por alguna extraña razón, me está devolviendo 0.

Gabo77_4-1690812863564.png

No entiendo por qué me resulta así… igualmente probé hacerlo a través de crear una medida maestra, pero con el mismo resultado. ¿Me podrían echar una mano? :disappointed_face:

 

Labels (2)
2 Replies
Digvijay_Singh

Not sure but below expression might have a problem - 

(Netwgt * Count({<Type={'B','R'}>} Type)) / 1000

You are multiplying a field (Netwgt) with an aggregated function Count. I don't feel that would work well.

Not sure if below is possible but for sure multiplying independent field with aggregated function like Count won't work for most of the data models.

Count({<Type={'B','R'}>} Type* Netwgt)) / 1000

Thanks,

 

 

Gabo77
Contributor III
Contributor III
Author

Hi @Digvijay_Singh i'm not sure if this is a problem... cuz then this output shouldn't be working... isn't??

Gabo77_0-1690822743233.png