Qlik Community

New to QlikView

Discussion board where members can get started with QlikView.

Not applicable

how can i get the current assigned cal users list?

Hi all,

     I know that i can see the all cal users in QMC, while i want to know is there any file which contain this user list in server ?

thanks,

zhou

8 Replies
Not applicable

Re: how can i get the current assigned cal users list?

You can find it from server log file.

MVP
MVP

Re: how can i get the current assigned cal users list?

You would find a file called CalData.pgo.xml in the server.

jonasheisterkam
Contributor III

Re: how can i get the current assigned cal users list?

Is this file not only created if i use the very unstable function pgoasxmlalso=1 in the settings.ini, but its the only way to find loosen Doc Cal from deleted files.

You can use the QlikView user Manager and use the ">file.csv" param in cmd, you can find it in the forum. Or write it self in c#, its very easy there are some tutorials to QMS API with code example and all functions you need.

Not applicable

Re: how can i get the current assigned cal users list?

Thanks Jona, Could you pls send me a link to find the QlikView user Manager?

thanks

zhou

Not applicable

Re: how can i get the current assigned cal users list?

Thank you Trsesco.

I did not find the xml file you specified on my server. Could you please tell me the directory to find it?

zhou

jonasheisterkam
Contributor III

Re: how can i get the current assigned cal users list?

Root folder, is define in the Management consol. But before you must add in C:\ProgramData\QlikTech\QlikViewServer Settings.ini the line PgoAsXmlAlso=1 under Settings 7 and stop Server Services for the change and start it after saving the ini.

jonasheisterkam
Contributor III

Re: how can i get the current assigned cal users list?

It is Part of the Power Tools. PowerTools 1.1 for QlikView

Highlighted
prathipsrinivas
Contributor

Re: how can i get the current assigned cal users list?

Hi 

I could not able to see Caldata.pgo.xml file eventhough i added PgoAsXmlAlso=1 in the settings.ini file.

Could you please guide me where would have I gone wrong?

 

Thanks,

Prathip