Skip to main content

Qlik Application Automation

Announcements
Welcome to Qlik Community! Check out our new navigation! FIND OUT MORE
cancel
Showing results for 
Search instead for 
Did you mean: 
JaMajka1
Partner - Creator II
Partner - Creator II

QAA - Transform List function -> List Contains

Hi guys,

 

there must be something I'm overlooking 🤔. I have a simple QAA where I'm trying to read the main information about Qlik users. 

 

JaMajka1_0-1648477685013.png

 In the Transform List I can easily read name, e-mail, etc. However, for the Roles list, I want to create separate binary fields (Developer, SharedSpaceCreator, ...).

JaMajka1_1-1648477746221.png

So, I used the formula with the function List contains. However, it always returns me the "False" output. I tried to specify Developer as a string and as you see on the screenshot also as a variable containing string. Still the negative output (even if the role is there). 

JaMajka1_2-1648477867467.png

Any ideas about what needs to be changed?

 

Thank you,

Maria 

Labels (1)
1 Solution

Accepted Solutions
blaise
Partner - Specialist
Partner - Specialist

you can actually do this directly in the transform list, just use a if() together with a "list contains";

"tenantAdmin": "{if: {$.transformList.item.roles} inList 'TenantAdmin', 1, 0}"

or as GUI;

blaise_0-1648479878338.png

Edit node: added my test QAA as an exported json

View solution in original post

5 Replies
blaise
Partner - Specialist
Partner - Specialist

I think you need to implode() the roles fields before

blaise
Partner - Specialist
Partner - Specialist

you can actually do this directly in the transform list, just use a if() together with a "list contains";

"tenantAdmin": "{if: {$.transformList.item.roles} inList 'TenantAdmin', 1, 0}"

or as GUI;

blaise_0-1648479878338.png

Edit node: added my test QAA as an exported json

JaMajka1
Partner - Creator II
Partner - Creator II
Author

Thanks for the reply. Hmmm... when I'm clicking through the GUI, I don't have the option for the Transform List to refer to the Transform List itself. Do you have it there? 

blaise
Partner - Specialist
Partner - Specialist

no there seems to be a bug/glitch there - I had to turn of formula parsing and show raw input, copy another row where i could refer to transformList and then turn on formula parsing and raw input and then i could work with the GUI again. I thought it was just a glitch for me so i didn't mentioned it.

It works fine as long as i dont run the automation, as soon as the ListUsers block has been run i cannot - GUI wise - select fields from in from my TransformList block. 

JaMajka1
Partner - Creator II
Partner - Creator II
Author

Same here, @blaise . So hopefully, they'll fix it soon :). In the meantime, thank you very much for your help!