Qlik Community

Qlik Compose for Data Warehouses

Discussion board for collaboration on Qlik Compose for Data Warehouses.

Announcements
Coming Aug. 9: New Simplified Authoring for Qlik Sense SaaS – For Details, CLICK HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
t_schueller
Partner - Contributor III
Partner - Contributor III

Qlik Compose - Snowflake issue: The remote server returned an error: (401) Unauthorized

Hi,

I used Qlik C4DW with snowflake and it worked fine. On the same server, I installed the new product Qlik Compose (merge between C4DW and C4DL).

In Qlik Compose when I try to connect to Snowflake with exactly the same parameters as C4DW, I have this issue: The remote server returned an error: (401) Unauthorized.

Do you have any ideas?

Qlik C4DW

t_schueller_0-1617097372848.png

Qlik Compose

t_schueller_1-1617097395086.png

 

Thanks,

Best regards,

Thibaut

Labels (1)
1 Solution

Accepted Solutions
t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Hi Tim,

I changed the agent from local to a remote (who doesn't exist) and then change it again to local and now it's working.

Thanks ofr your help.

Thibaut

View solution in original post

12 Replies
Brian_Jones
Employee
Employee

The connection parameters are unchanged between Qlik Compose for Data Warehouses and Qlik Compose.

However, the default directory has changed to C:\Program Files\Qlik\Compose. I'd suggest checking the following:

Check your Snowflake JDBC driver is in the following path for Qlik Compose. 

C:\Program Files\Qlik\Compose\java\jdbc

 ( I'm using snowflake-jdbc-3.12.2.jar)

Check your Snowflake ODBC driver is current.

  • Download and install Snowflake ODBC driver for Windows 2.18.1 or above.

 

 

t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Hi Brian,

Thanks.

That's the first thing I checked. I copied all JBDC used in C4DW to the new default directory  of Qlik Compose.

Best regards,

Thibaut

TimGarrod
Employee
Employee

Do you have a source connection tied to a Replicate task? 

This maybe your connection to Replicate from Qlik Compose? or even a conncetion to a source system if you have that defined. 

Can you check those and also type in your passwords again ? 

The easy way to tell if the Snowflake connection is working is to edit the connection and click the elipses to select your dw schema / database.   If Compose can connect to Snowflake - you'll get the list.  If its having an issue connecting to Snowflake - you'll get an error.

t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Hi Tim,

The connection to my replicate server is working and the connection to the source database is also working (Discover option works properly).

If I select a dw schema or database or Warehouse, it's working. The test connection is not working. In Data Warehouse section, run ETL set is not working with the same error (401 Unauthorized).

 

TimGarrod
Employee
Employee

Compose connects with the UI via ODBC and at runtime with JDBC via the Java agent.  So this appears to be a jdbc related issue (Test connection tests both ODBC and JDBC)... 

Can you  turn on logging for the agent and provide the agent log (you can private message me instead of posting here in the community)  - or I suggest opening a ticket with support.   But it appears to be a jdbc issue based on what you've said above.     Seems like the driver is there, or you'd normally get some type of class not found error.    

Are you using a proxy at all to connect to snowflake?

 

t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Actually the 401 is sent by the Compose server. I can't change the log level, I have the same error. Any idea? Otherwise i will open a case with support.

Thanks,

Thibaut

TimGarrod
Employee
Employee

DO you have Compose DW (7.x) on the same server?   

If so - can you shut down ComposeDW - make sure there are no java processes running on the server (which is the Compose agent) and restart QLik Compose.   I'm wondering if its a port issue with the 2 running on the same server.  (if thats what you've got running on your server)

t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Yes. I disabled C4DW and C4DL services and restart the server but still the same issue.

t_schueller
Partner - Contributor III
Partner - Contributor III
Author

Hi Tim,

I changed the agent from local to a remote (who doesn't exist) and then change it again to local and now it's working.

Thanks ofr your help.

Thibaut