Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Qlik Analytics Tour 2020 Online. Begins August 10th. Register Today
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Partner
Partner

Empty levels in pixel perfect report

Hi,

I have created a pixel prefect report.
I use several levels. Sometimes all levels are used. Some times just the first two of three levels are used. The problem is now that my empty levels are shown as empty records. How can I filter that those levels are not used when there is no data for this level?

nprinting_designer.png

The result:

empty_records.png

Level 5 and six are empty.

Regards,
Wouter

Tags (2)
1 Solution

Accepted Solutions
Highlighted
Partner
Partner

Re: Empty levels in pixel perfect report

Thanks Lech. It doesn't work for me. I have a working solution.

1. Select the report bound level you want to remove if there is no data

2. Set Visible to No

3. Press on the error

step1.png

4. Click on the formatting Rules and create a new Rule.

step2.png

5. Create your condition.

6. Set visible to Yes. You want to display the level when there is some data. This overrules the visible = no in the previous setting (step 2)

7. Link it tho the correct data member (same as in step 1.)

Step3.png

Click close and press on the arrow to apply your rule to the control.

step4.png

Regards,

Wouter

View solution in original post

4 Replies
Highlighted

Re: Empty levels in pixel perfect report

Could be you forget to delete extra boxes in Nprinting? Can you check the same

Before develop something, think If placed (The Right information | To the right people | At the Right time | In the Right place | With the Right context)
Highlighted
Partner
Partner

Re: Empty levels in pixel perfect report

Unfortunately not. When I set my last level to hide, the last empty row is disappeared. I have to do something with a check if the level is empty or not.

Highlighted

Re: Empty levels in pixel perfect report

Hi,

Maybe try to Edit LEVEL Properties -> Data->Filter String -> ADD (try here to add some kind of filtering like: " Is not null " or something - ()look at second screenshot)

I am not familiar with Pixel Perfect properties as there was never a proper help document created for i - so this is just a pure guess

test.png.

2.png

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Highlighted
Partner
Partner

Re: Empty levels in pixel perfect report

Thanks Lech. It doesn't work for me. I have a working solution.

1. Select the report bound level you want to remove if there is no data

2. Set Visible to No

3. Press on the error

step1.png

4. Click on the formatting Rules and create a new Rule.

step2.png

5. Create your condition.

6. Set visible to Yes. You want to display the level when there is some data. This overrules the visible = no in the previous setting (step 2)

7. Link it tho the correct data member (same as in step 1.)

Step3.png

Click close and press on the arrow to apply your rule to the control.

step4.png

Regards,

Wouter

View solution in original post