Qlik Community

Qlik NPrinting Discussions

Discussion Board for collaboration on Qlik NPrinting.

alindquist
New Contributor III

NPrinting Report With Password Error

I'm having an issue when trying to generate an NPrinting Excel report that contains "Password to open" report security.

I created a Report Task that delivers an Excel report to a specific user. I added the report to the list of reports on the task, and in the Advanced column I checked the box "Enable security". Then I selected the option "Protect using recipient passwords" in the "Password source" drop down list. In the message section, I checked the box for Send Email and the box for Attachments. There are no filters set in the report task.

In the settings of the Excel report, I enabled a cycle to cycle over a specific field (for this description I will call that field "Value"). Then I set up dynamic naming to include the cycle field, the date, and the report name. There are no filters set in the report settings.

Lastly, in the settings of the one user I'm sending this report to, I added a "password to open" in the Report Security section. In the recipient filters, I added a new filter and chose 3 values from the field that I'm cycling the report over (for this description I will call those "Value1", "Value2",  and "Value3" from the "Value" fileld).

The end goal of this is to send an email with three attached, password protected Excel reports; one with data for "Value1", one with data for "Value2", and one with data for "Value3". When I run the Report Task, it runs successfully and it sends an email with three Excel reports attached, each with the correct report names based on the filter values. However, when I open each of those reports and enter the password, they all only include data for Value1 (despite having the correct report name). For example, the report for Value2 is called "Value2_2015-10-02_Report Name", but it only includes Value1 data. It's as if the cycle part works correctly, but the filter gets stuck on Value1.

If I disable report security within the Report Task and re-run, I don't get this error; each report has the correct data. Is this an issue anyone else has encountered or a known issue with report security?

1 Solution

Accepted Solutions
djk
Valued Contributor III

Re: NPrinting Report With Password Error

Hi Andrew,

Good catch - I can replicate this bahaviour. I have created a demo project and registered a case with R&D. If you open a case with Qlik Support via the Partner Portal we can give you some more details like the case number etc.

Thanks for bringing this to our attention.

Best,

Daniel.

3 Replies
djk
Valued Contributor III

Re: NPrinting Report With Password Error

Hi Andrew,

Good catch - I can replicate this bahaviour. I have created a demo project and registered a case with R&D. If you open a case with Qlik Support via the Partner Portal we can give you some more details like the case number etc.

Thanks for bringing this to our attention.

Best,

Daniel.

alindquist
New Contributor III

Re: NPrinting Report With Password Error

Thanks Daniel. I created a support case in the Partner Portal, and I referenced this forum post and the fact that you registered a case with R&D. I also copied my original post and used that as the steps to reproduce the issue. Is that enough information? Do I need the number for the case you registered with R&D?

djk
Valued Contributor III

Re: NPrinting Report With Password Error

Hi Andrew,

All good. I see that you have been contacted by Frank via our Support system. Please continue to follow the case there.

Thanks again.

- Daniel.

Community Browser