Skip to main content

Qlik NPrinting

Discussion Board for collaboration on Qlik NPrinting.

Announcements
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
GavK
Contributor III
Contributor III

NPrinting- Connecting to Qlik Sense apps

Hi

I'm having issues with connections in NPrinting when trying to connect to all Qlik Sense apps (All connections to Qlikview are working fine)

When I run the verification check on the connection, Everything appears to be ok

GavK_0-1656663537363.png

But the connection always fails with "Cache Generation Failed. NPrinting Engine Failed to Open Document"

GavK_1-1656663626908.png

This is the log file from the NPrinting server

GavK_2-1656663969087.png

I've also tried recreating the connection but still get the same error. I have previously connected to this app from NPrinting so dont believe the issue is related to unsupported chart objects in the app.

Qlik Sense version is May 2022 Patch 3

Nprinting is version May 2022 (Version: 22.15.2.0)

I can also log onto the NPrinting server and open the Qlik Sense apps via a browser.

What am I missing?

Labels (2)
1 Solution

Accepted Solutions
Lech_Miszkiewicz

At this stage I would suggest to ensure that NPrinting service account is a root admin in Qlik sense and that Qlik Sense certificates are re-issued and re-installed: https://help.qlik.com/en-US/nprinting/May2022/Content/NPrinting/DeployingQVNprinting/NPrinting-with-...

Also check this: https://help.qlik.com/en-US/nprinting/May2022/Content/NPrinting/Troubleshooting/NP-wont-read-QS-cert...

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.

View solution in original post

9 Replies
Lech_Miszkiewicz

  • Do you have section access in this Qlik Sense document?
  • Does your service account belong to section access table and has Admin rights?
  • What setting have you setup in your connection screen

cheers

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
GavK
Contributor III
Contributor III
Author

Hi Lech

Thanks for the reply. The app I used as an example didnt have any section access. 

To be on the safe side, I've created new app with a single table in it with 94 rows of data

(I've blurred out the Proxy Address and Identity but happy to show these offline if needed)

GavK_0-1656673053211.png

I'm seeing this message on the 'View Connections' screen (Connection failed on some NPrinting Engines)

(We only have a single Nprinting Engine)

GavK_1-1656673159593.png

 

And get this error when viewing the tasks (Same as previous)

GavK_2-1656673277310.png

Feels like some kind of authentication issue but dont understand why the verification checks are all green ticked/successful if this is the case. I'm also able to use the user account  that I'm using in the connection to log on manually onto Qlik Sense

 

Lech_Miszkiewicz

Interesting - just wanted to confirm few more things:

  1. NPrinting is running on dedicated server (nothing else is installed on it)
  2. You are using Windows authentication NTLM
  3. You are using HTTPS
  4. You are having dedicated service accounts for your services
  5. You are 100% sure there are no unsupported objects (extensions which could be unsupported or cause actions/problems/ triggers/ alternate states etc...)
cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Ruggero_Piccoli
Support
Support

Hi,

I would like to add to @Lech_Miszkiewicz 's list the suggestion to check that the Engine is correctly configured in Qlik NPrinting Web Console Admin setting and it is green online status.

Best Regards,

Ruggero



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
GavK
Contributor III
Contributor III
Author

Hi Lech

  1. Yes confirmed. Qlikview & Qlik Sense both have their own dedicated servers
  2. Yes we use windows authentication NTLM although the file permissions on the Qlik Sense apps are set to allow everyone read access.
  3. Yes using HTTPS for both Qlik Sense and Nprinting (NPrinting SSL certificate is self signed)
  4. We have a dedicated service account for Nprinting. Qlik Sense and Qlikview both use the same service account
  5. Yes 100% sure.I created a test app in Qlik Sense and simply loaded 100 records into a standard table and still got the same issue
  6. See below for NP Engine status (Ruggero's comment). Connections to Qlikview work fine so believe Engine is fine

  

GavK_0-1657014835328.png

 

Thanks

Ruggero_Piccoli
Support
Support

Very strange. Did you tried to create a connection to another Qlik Sense app?



Best Regards,
Ruggero
---------------------------------------------
When applicable please mark the appropriate replies as CORRECT. This will help community members and Qlik Employees know which discussions have already been addressed and have a possible known solution. Please mark threads with a LIKE if the provided solution is helpful to the problem, but does not necessarily solve the indicated problem. You can mark multiple threads with LIKEs if you feel additional info is useful to others.
GavK
Contributor III
Contributor III
Author

Yes Indeed. I created a Test App and Test Connection in NP to the Qlik Sense app I mentoned in my previous reply  (see point 5)

GavK_0-1657016939008.png

 

Lech_Miszkiewicz

At this stage I would suggest to ensure that NPrinting service account is a root admin in Qlik sense and that Qlik Sense certificates are re-issued and re-installed: https://help.qlik.com/en-US/nprinting/May2022/Content/NPrinting/DeployingQVNprinting/NPrinting-with-...

Also check this: https://help.qlik.com/en-US/nprinting/May2022/Content/NPrinting/Troubleshooting/NP-wont-read-QS-cert...

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
GavK
Contributor III
Contributor III
Author

Hi Lech

I've re-issued the certificates and re-installed on the NP Server and this seems to have resolved the issue. Many thanks for your help 😀 (and to @Ruggero_Piccoli )