Skip to main content
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
Showing results for 
Search instead for 
Did you mean: 
Contributor II
Contributor II

Qlik Nprinting SAML Authentication Issue

Hello Team,

We are trying to work on SAML authentication on Qlik Nprinting (November 2018 version).

We have defined the SAML settings through web console for Qlik NPrinting newsstand (attached the SAML_settings screenshot for your reference).

We are using ForgeRock OpenAM SAML identity provider and gathered the idp metadata file and associated it with the SAML settings on NPrinting.

Once the setup is complete, we tried to access the newsstand URL.

It shows the login page with the SAML login button (as expected).

Once we enter the credentials, the page refreshes as if the access is successful, but then lands back on the login page with a message on the top.

Message says "you need to be logged in to access this part of the application"

We tried to understand the issue through SAML tracer - noticed that we get "HTTP/2.0 401 Unauthorized" error and 403 forbidden error

Tried to check NPrinting scheduler and web engine logs. There is an error with "reading SAML attributes"

Attached the web engine logs file for reference.

We tried to enable debug level logs as per the below document.

Even after making the changes and restarting the service, we don't see the new debug level logs generated.

Please let me know if anyone has experienced such issue before and assist us with the possible solution.

I will look forward to your response.



4 Replies
Partner Ambassador/MVP
Partner Ambassador/MVP

It may be a silly question but....

Have you created an User in "NPrinting Console: Admin-->User" with admin privileges who will have properly populated Domain Name /or email field for SAML authentication? 



cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Contributor II
Contributor II

Hello Lech,

Yes, I have the user Email and Domain information populated and Administrator and newsstand user roles assigned to the user.

We are running into this issue, inspite of giving the user admin rights.




I have the same issue, were you able to get this resolved?


@shemeel this thread is 4 years old, please start a new one thanks!