Skip to main content
Announcements
Defect acknowledgement with Nprinting Engine May 2022 SR2, please READ HERE
cancel
Showing results for 
Search instead for 
Did you mean: 
daveatkins
Partner - Creator III
Partner - Creator III

Sending email reports from NPrinting

I am having a lot of frustration with what I thought was the core purpose of NPrinting. All I want to do is email reports to people. It appears I need to create user accounts for all these people, assign them groups, roles, etc.

I have found one workaround; I can paste the email addresses onto the bcc: line of the publish report task, but that is very limited and not a great solution.

My immediate issue is that I have created a user, but NPrinting will not send the email because, from the log file: (actual names are replaced by words in brakets)

The user [userid] for the task [taskname] has no permission to see the published reports. No email will be sent. 

User [email address] is inserted as recipient in task [taskname] but no destination is configured. Report will not be generated

on these items,

1. user has the user role...what else do they need? The User role has access for all apps to Published Reports (default setting)

2. email is checked off in the destinations tab for this user.

1 Solution

Accepted Solutions
Stephen_Jasionowski

David -

At the very least, they need to have the Newsstand User role (I realize this is not intuitive). We have on our roadmap a role for email delivery only.

Please try to give them the Newsstand User role and let me know if that resolves the issue.

View solution in original post

5 Replies
Stephen_Jasionowski

David -

At the very least, they need to have the Newsstand User role (I realize this is not intuitive). We have on our roadmap a role for email delivery only.

Please try to give them the Newsstand User role and let me know if that resolves the issue.

daveatkins
Partner - Creator III
Partner - Creator III
Author

I created a new role "Email Only" and added permission, for all apps, to View Reports. This seems to have solved the issue.

Chanty4u
MVP
MVP

Hi lech_miszkiewicz‌   am facing same issue  what is the solution for this?

The user [userid] for the task [taskname] has no permission to see the published reports. No email will be sent.

User [email address] is inserted as recipient in task [taskname] but no destination is configured. Report will not be generated

Lech_Miszkiewicz

Well,

My take on this is following:

  • Whoever is going to receive a NPrinitng report needs to exist in User List and should have a role assign to its name. This Role controlls what users see/not see.
  • second thing i take into account is whether there is section access and data reduction and how does it corelate to Domain Account for recipient/user in NPrinitng ?

Error you are getting is basicly suggesting that somebody from the user list does not have a role or privilage to receive a report. As it clearly says in USER ID and TASKNAME ID you can validate it quickly who it is and make sure this person does not have filters assigned or exist in section access or maybe does not have role... etc...

regarding second error it may be related to first one, but also you could add a user to recipient list but could "untick" all destinations next to their names in Publish task.. this will create a report for a user, but report does not go anywhere as it hasn't got assigned destination..

I am not sure how i can help you as it resides in actual task/user/qlik app setup and there is many factors.

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.
Lech_Miszkiewicz

one more comment to above mentioned:

I am not talking about CC recipient list as there are different rules regarding them.

cheers

Lech

cheers Lech, When applicable please mark the correct/appropriate replies as "solution" (you can mark up to 3 "solutions". Please LIKE threads if the provided solution is helpful to the problem.