Do not input private or sensitive data. View Qlik Privacy & Cookie Policy.
Skip to main content

Announcements
Share your agentic AI experience, learn from others, and earn a new badge: Put Agentic AI to Work
cancel
Showing results for 
Search instead for 
Did you mean: 
suvbin
Creator III
Creator III

Snowflake target

Hi , 

00032512: 2024-02-12T21:16:30 [TARGET_LOAD     ]E:  RetCode: SQL_ERROR  SqlState: 22000 NativeError: 100144 Message: Invalid UTF8 detected in string '��'

  File '1/LOAD00000044.csv.gz', line 4063416, character 130

  Row 4063342, column "CDPOS"["VALUE_NEW":17]

  If you would like to continue loading when an error is encountered, use other values such as 'SKIP_FILE' or 'CONTINUE' for the ON_ERROR option. For more information on loading options, please run 'info loading_data' in a SQL client. [1022502]  (ar_odbc_stmt.c:5003)

Request your help on this.

 

Labels (3)
5 Replies
aarun_arasu
Support
Support

Hello @suvbin ,

 

Thanks for reaching out to Qlik community.

Can you please try the below settings and let us know if that helps
 

task settings->character substitution->character set->UTF-8 to U+0. 

Reload the table

 

Regards,

Arun

 

SachinB
Support
Support

Hello @suvbin ,

Thank you for reaching out to the Qlik community!

Solution:
1)Task settings->character substitution->character set->UTF-8 to U+0
2) Reload the task again

Please try it and let us know for the same.

 

Regards,

Sachin B

john_wang
Support
Support

Hello @suvbin ,

If you like to figure out the root reason of the invalid UTF8 chars, we may try below steps to get the reason:

  1. Open Snowflake target endpoint
  2. Go to the Advanced tab
  3. Open Internal Parameters
  4. Add new parameters named keepCSVFiles & keepErrorFiles
  5. Set their values to TRUE

Recreate the error, then check the generated CSV files on Replicate Server task sub-folder to get further understanding of the error. Maybe it's code page incorrect setting, or some special chars which is not a UTF8 char, or something else. Comparison the chars with source side Database data may get clues.

Hope this helps.

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!
suvbin
Creator III
Creator III
Author

Enabled character substitution for utf-8 . Again getting the same error . 

john_wang
Support
Support

Hello @suvbin ,

If we can figure out the root cause then it's easier to tell a workaround or solution. Any clue from the interim CSV files?

thanks,

John.

Help users find answers! Do not forget to mark a solution that worked for you! If already marked, give it a thumbs up!