Qlik Community

Qlik Sense App Development

Discussion board where members can learn more about Qlik Sense App Development and Usage.

mydearleo
New Contributor II

having problem converting from SQL Date format

Hi all,

recently i have come across with an issue converting SQL date 'yyyy-mm-dd' into qlik 'dd/mm/yyyy'.

first of all, i have to declare that it is not a wide spread issue, i have no problem converting dates and store them into QVD.

it is particularly happening on one of the hundreds of QVDs i ever handled.

the difference i can see from comparing with other working QVDs is that in this particular QVD generation process, i threw in a lot of temp table processing on SQL side. for example, i select data from source SQL table into a tenp table, then manipulate the data and select into another temp table, etc. at the last step, i grab all the data from the final temp table and start formatting the date fields.

i tried, DATE(field), DATE(DATE#(field, 'yyyy-mm-dd')), DATE(DATE#(field,'yyyy-mm-dd'),'dd/mm/yyyy'), and many more, none of them worked, some even converted the dates wrong.

however, if i leave as is, when i read in data from the QVD, and simply put a date() around the fields, it works.

has anyone come across this issue before?

2 Replies
antoniotiman
Honored Contributor III

Re: having problem converting from SQL Date format

Hi,

try to change Format Date in Upper Case Like

YYYY-MM-DD and DD/MM/YYYY

because mm in format date/time is minutes and MM is Months.

Regards,

Antonio

mydearleo
New Contributor II

Re: having problem converting from SQL Date format

sorry for the confusion, everything is in upper case, i was just too lazy