Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

flyingcheesehea
Contributor II

Installing SSL certificate on Sense server

Hi all,

Yesterday I attempted to install a real, signed certificate on our Sense server as detailed here:

https://help.qlik.com/sense/en-US/online/Subsystems/Qlik_Management_Console_help/Content/ServerUserG...

Unfortunately, after that was done, I couldn't get in via either SSL or regular HTTP. When I attempted to get in via SSL I would get a server not responding error, and when attempting via HTTP I was asked for my credentials three times before being presented with a blank white screen. This was when connecting to either hub or qmc.

I'm not looking for how to get in and fix it - We're just going to restore from backup and start over. I just want to know how to do it right!

Do I need to remove the spaces from the thumbprint when I paste it into the QMC? Anything else that might not be obvious to someone (me) who isn't really much of a Windows admin?

Thanks!

26 Replies
korsikov
Valued Contributor II

Re: Installing SSL certificate on Sense server

How I did it.

Received from domain CA certificate on the server. If not necessary to, I will describe how to do this.

further open the properties of the certificate, tab "details" option "Thumbprint"

and copied value as is, with spaces.

Open QMC in my server

https://fly/qmc/proxies

Edit Proxy, check Security and paste value in "SSL browser sertificate thumbprint" with space.

Restart Qlik Sense Web Server.

enjoy!

ssl1.png

ssl2.png

edwinwitvoet
New Contributor III

Re: Installing SSL certificate on Sense server

I exactly followed the process above for installing a server SSL certificate (both with entering the thumbprint with and without spaces). After saving the thumbprint, connection is lost and I cannot connect to QMC anymore.

Firefox : "The connection was interrupted"

- How to rollback?

- How to find out what actually goes wrong?

Appreciate any suggestions

edwinwitvoet
New Contributor III

Re: Installing SSL certificate on Sense server

OK, I got my SSL certificate running by

1. stopping the qlik repository service,

2. installing my certificates on the windows server

3. entering the SSL browser certificate thumbprint in the proxy (with the whitespaces)

4. removing the qlik certificates

5. restart the qlik repository service (which re-installs the qlik certificates again)

jcampbell
Contributor

Re: Installing SSL certificate on Sense server

I had the same problem, the QMC was busted, but following your steps, removing the qlik certs didn't help.  I had to roll back a VM snapshot.   It shouldn't be this difficult to get a cert working.    Any other suggestions?    Thanks.

edwinwitvoet
New Contributor III

Re: Installing SSL certificate on Sense server

I worked through the same problems with QMC getting busted when adding the thumbprint.

Turned out that my certificate was not installed properly.

I also had to reinstall the VM snapshot before I could get back into the QMC. Qlik Sense should be more robust to that indeed.

fasuhaibani
New Contributor III

Re: Installing SSL certificate on Sense server

Hi Edwin,

I am facing the same issue you were facing; however, I was not able to set the thumb print when the service it stopped. Any ideas how to get the Qlik Sense to recognize the SSL certificate?

Thanks!

alexbransky
New Contributor

Re: Installing SSL certificate on Sense server

I ended up getting things working again by running the query below directly in the Postgres database that Qlik Sense is using behind the scenes (note that I only had one server and there was only one row in the table).

update public."ProxyServiceSettings" set   "SslBrowserCertificateThumbprint" = null

alexbransky
New Contributor

Re: Installing SSL certificate on Sense server

In what way was your certificate not installed properly?  I'm having the same problem but not sure what to do differently.

Not applicable

Re: Installing SSL certificate on Sense server

Hi Alex,

I tried your solution without success, editing the value in the DB. Could you please give me some more details to restablish Qlik? Is there any other actions missing?

Thanks

Community Browser