Qlik Community

Qlik Sense Deployment & Management

Discussion board where members learn more about Qlik Sense Installation, Deployment and Management.

edwinwitvoet
New Contributor III

QS 3.0 bug ? : EXECUTE CMD statement does not work

After upgrading to QS 3.0 the EXECUTE cmd does not work.

Double checked all settings as documented here : Execute ‒ Qlik Sense

When running in QS3.0 the following error is shown : EXECUTE statement requires Override Security

Anyone else facing the same problem?

Any workaround?

Tags (1)
15 Replies
erwinvink
New Contributor II

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

Same problem here, no solution found yet. Was working until QS 2.2.4. After update execute won't work anymore.

eliran_s
Contributor II

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

Same here, working fine on 2.2.4 server, not working on Sense Server 3.0.0

dverbeke
Contributor III

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

To allow Execute in Qlik Sense, you must enable Legacy mode.


Dion

eliran_s
Contributor II

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

It *was* working before, other then upgrading the server, there was no change.

I think it's a bug in the version.

There is already a ticket open on the subject at Qlik.

This is the relevant info to enable it on previous versions

https://help.qlik.com/en-US/sense/3.0/Subsystems/Hub/Content/Scripting/ScriptRegularStatements/Execu...

https://help.qlik.com/en-US/sense/3.0/Subsystems/Hub/Content/LoadData/disable-standard-mode.htm

edwinwitvoet
New Contributor III

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

Exactly. Thanks for your replies.

Where did you see that there is a ticket open @ Qlik?

I have submitted a support request myself on July 1st, but haven't heard anything yet.

Any workarounds?

eliran_s
Contributor II

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

What I have done, is scheduling a windows based task.

It's not the solution I need, but that's what I got at the moment.

I hope Qlik will issue a fix soon.

dverbeke
Contributor III

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

It says it there:

This statement is not supported in standard mode. See File system access restriction

I hope they find a better way to run external commands. Like R.

erwinvink
New Contributor II

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

Hi Dion,

Thanks for your answer. But like I said, execute was working before the update. That means that I know how to disable standard mode etc.. After the update, none of the settings was changed but execute isn't working anymore. This have nothing to do with standard mode. For your information, I (and I guess Edwin also, cause he said he checked everything twice) enabled legacy mode and add override security settings to the settings.ini file.

So far as I can see, it's a bug in the update and nothing else.

edwinwitvoet
New Contributor III

Re: QS 3.0 bug ? : EXECUTE CMD statement does not work

That's correct.

Today Qlik Support confirmed that this is now officially listed as a bug report in 3.0 and given high priority. Solution / workaround is expected in the coming days. Keep you posted ...

Information from Qlik Support below:

Related Bug : Legacy mode in Sense 3.0. does not work

Bug Id : QLIK-61452

Community Browser